1

Is it possible to use AMDGPU-PRO driver with a newer Kernel under Ubuntu 16.04?

I couldn't find much information, sorry if I missed something.

So I converted my friend to linux. Since Linux Mint 18.2 was released yesterday and it's based on Ubuntu, I installed it for him with kernel 4.10.

He got a XFX Fury. I tried installing the driver from AMD (AMDGPU-PRO for Ununtu 16.04) but after rebooting, I got black screen with an underscore (not blinking). Tried with kernel 4.8, 4.10, 4.12.

Rebooting in recovery mode, I found out there is an error with the display in xorg.log. Trying to boot with nomodeset works in software rendering mode.

I reinstalled Linux and now everything is running perfectly without this driver, but Overwatch need a videocard installed :P. (Running kern. 4.10)

I personally have an old graphic card (GTX 580) which runs beautifully under Kernel 4.12, released yesterday, with both closed-source driver and nouveau.

I was wondering why the AMD driver wasn't working. Unfortunatly I don't remember the exact error message - but I'll try to find the same message ont he internet and update this question. In the mean time I though maybe someone had a solution.

Thanks to anyone how may have some tips for us!

Cheers!

Little disappointment addition: I guess Ubuntu people doesn't care since they asked me to post this here instead - for what the linux community is worth :P

  • I'm having similar issues. I tried amdgpu-pro on 4.14.0-rc1 and got some broken symbols errors. Also tried kernel 4.12. However, I don't think even the amdgpu open-source driver is active in my setup. Even that may be sufficient. Isn't nouveau for nvidia cards? See my related question here: unix.stackexchange.com/questions/394661/… – nnyby Sep 27 '17 at 0:59
0

I am using a RX470 with the open source AMDGPU driver and kernel 4.10 on Linux Mint 18.4 Mate and I can't see any difference from before when I had 4.8 and AMGDPU-PRO, including Steam games.

Maybe you should try amdgpu. In fact it got installed by default when I installed 18.2, tested with glxgears then installed Steam and it just worked.

Some games did not like the Steam overlay and I had to disable that, but that's what I do anyway.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.