1

I have an access to a server with CentOS 6.8 via ssh and I want to run my python projects in Jupyter there without distributing global python.

What I tried is install Jupyter under virtualenv and it gives me Permission denied when installing terminado. I have a root access and so I forced it to pip install jupyter. Yet when I launch Jupyter without root in or out of virtualenv I get ImportError: No module named 'jupyter_core.command'. I can launch Jupyter with root but that is not a very good idea.

I also tried to do it with a relocatable virtualenv and this didn't work.

Can I somehow run Jupyter in this circumstances without root access?

EDIT: A bit of details

Current problem is that when I run jupyter notebook without root I get: ImportError: No module named 'jupyter_core.command'

I installed jupyter under virtualenv with pip (pip install jupyter) which without root gives me

Collecting terminado>=0.3.3; sys_platform != "win32" (from notebook->jupyter)
  Downloading terminado-0.6.tar.gz
    Complete output from command python setup.py egg_info:
    running egg_info
    creating pip-egg-info/terminado.egg-info
    writing requirements to pip-egg-info/terminado.egg-info/requires.txt
    writing dependency_links to pip-egg-info/terminado.egg-info/dependency_links.txt
    writing pip-egg-info/terminado.egg-info/PKG-INFO
    writing top-level names to pip-egg-info/terminado.egg-info/top_level.txt
    writing manifest file 'pip-egg-info/terminado.egg-info/SOURCES.txt'
   error: [Errno 13] Permission denied: '/usr/local/lib/python3.5/lib2to3/Grammar3.5.0.final.0.pickle'

    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-sol3g9mh/terminado/

((this worked with root))

I also tried to do the same but on my own PC, where I didn't use root access but user virtualenv with --relocatable option.

  • Which commands have you been using and which exact errors messages did you get? – Wieland Jul 3 '17 at 17:22
  • @Wieland Added some details. Please feel free to ask anything else about the process. – UpmostScarab Jul 3 '17 at 17:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.