1

I am using GKSU for switching user in my Linux terminal and I want to disable "Remember password" option in that Pop-up menu due to security reasons. I am not sure how to achieve that.

Mentioned below is the only trial i tried in the system, which did not work too.

gconftool-2 --direct --config-source xml:readwrite:/etc/gconf/gconf.xml.mandatory --type bool --set /apps/gksu/save-to-keyring false

System config: Os : Debian 8 Desktop Environment : LXDE

Command used for this operation :

gksu -u test /usr/bin/xterm

Attached screenshot for the same

enter image description here

I remember password option to be completely disabled

1

Thought this might help someone

gksu -a works actually, was not able to get it through man pages

this link talks about the implementation : gksu bug reference

0

You can change the settings in gconf-editor.

gksu gconf-editor

once there set /app/gksu/save-to-keyring to false and set it mandatory.

Edit

Try this to disable gnome-keyring:

System-> Preferences-> Startup Applications 

and uncheck

gnome-keyring-daemon

then log out and in and the application shouldn't start anymore. You can also unset the execute permissions of /usr/bin/gnome-keyring-manager. You cannot simply uninstall it, because it would break programs that use it.

  • In my question I have executed the same command via gconftool-2, Do you find any error in that command ?? – Ragav Jul 3 '17 at 9:32
  • If it really doesn't work, why bother removing if you simply could add a master keyring password? Every time a saved password should be used you have to enter the master password to be able to access it. – ADDB Jul 3 '17 at 9:35
  • Technically i do not want any keyring storage, I want user to enter password every time. – Ragav Jul 3 '17 at 9:39
  • @Ragav edited my answer, that way you could disable the keyring. – ADDB Jul 3 '17 at 9:41
  • I did try that , changed execution permission for "gnome-keyring-manager" & gnome-keyring . gksu still prompts with remember password and when i select "Remember password" for this session and reopen GKSU system hangs – Ragav Jul 3 '17 at 10:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.