2

I fetched cryptodev source from http://nwl.cc/pub/cryptodev-linux/cryptodev-linux-1.9.tar.gz to directory ~/cryptodev, I unpacked tar archive and I entered into ~/cryptodev/cryptodev-linux-1.9 directory. I followed instructions on https://github.com/cryptodev-linux/cryptodev-linux/blob/master/INSTALL and I enter make command and I got below error:

hubot@hubot-vps:~/cryptodev/cryptodev-linux-1.9 $ make
make -C /lib/modules/4.9.24-v7+/build M=/home/hubot/cryptodev/cryptodev-linux-1.9 modules
make[1]: *** /lib/modules/4.9.24-v7+/build: No such file or directory.  Stop.
Makefile:27: recipe for target 'build' failed
make: *** [build] Error 2

I stopped at this error and I do not know what should I do next. I count on help. Thank you in advance.

  • ls: cannot access /lib/modules/4.9.24-v7+/build: No such file or directory – java-devel Jul 1 '17 at 15:09
  • 1
    @GAD3R 4.9.24+ 4.9.24-v7+ 4.9.28+ 4.9.28-v7+ – java-devel Jul 1 '17 at 15:09
  • @GAD3R Linux hubot-vps 4.9.24-v7+ #993 SMP Wed Apr 26 18:01:23 BST 2017 armv7l GNU/Linux – java-devel Jul 1 '17 at 15:29
  • 1
    I'm trying install cryptodev on Raspbian with enabled crypt luks. – java-devel Jul 1 '17 at 15:30
  • 2
    sudo apt-get install raspberrypi-kernel-headers – Mark Plotnick Jul 1 '17 at 20:35
1

Not sure if it's still relevant, but I've had similar issue and ,as Mark Plotnick said in the comments, the following command fixed it:

sudo apt-get install raspberrypi-kernel-headers
  • This fix didn't work for me on Raspbian GNU/Linux 9 \n \l. The build directory still doesn't exist – Dave B Dec 30 '18 at 1:50
  • Have you tried creating /lib/modules/4.9.24-v7+/build manually? – skipper Jan 29 at 8:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.