1

I have a desktop pc with Arch Linux installed and an AOC screen connected via DisplayPort.

A couple weeks ago I switched to i3 window manager from Xfce desktop environment and removed all xfce packages including power management.

Now I start the wm using startx command. My .xinitrc is as follows:

#!/bin/sh
userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap

if [ -f "$userresources" ]; then
    xrdb -merge "$userresources"
fi

if [ -f "$usermodmap" ]; then
    xmodmap "$usermodmap"
fi

# start some nice programs
if [ -d /etc/X11/xinit/xinitrc.d ] ; then
 for f in /etc/X11/xinit/xinitrc.d/?*.sh ; do
  [ -x "$f" ] && . "$f"
 done
 unset f
fi

# turn off screen blanking and turn on energy star features
xset s off
xset dpms 300 600 1800

i3 & wmpid=$!

[ -f /etc/xprofile ] && . /etc/xprofile
[ -f ~/.xprofile ] && . ~/.xprofile

# Wait for i3 wm to exit
wait $wmpid

When I lock my computer and leave it hanging, after a while the screen goes into power saving mode (which I think is 30 mins because I set third parameter of xset dpms command to 1800 ? ). I can't get the screen to wake by moving mouse or pressing keyboard buttons. Can not even use power button of the screen, or even input button. Nothing seems to work. The only thing that does is plugging out the screen and plug in again.

I did not have this problem when I was using Xfce and I am not sure how the energy star feature works.

I tried disabling deep sleep mode (or so I think i did) by changing the line xset dpms 300 600 1800 to xset dpms 300 600 0

I even tried to set the values to 10, 20 and 30 seconds to see if deep sleep is the problem.But, after 30 seconds I can use the mouse to wake the screen. So I am not entirely sure what the problem here is.

What am I doing wrong ?

closed as off-topic by Jeff Schaller, Rui F Ribeiro, jimmij, Networker, Anthon Jul 3 '17 at 13:48

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jeff Schaller, Rui F Ribeiro, jimmij, Networker, Anthon
If this question can be reworded to fit the rules in the help center, please edit the question.

0

It turns out it has nothing to do with screen saver or dpms settings.

I am using Mons to handle multi-screen. The daemon running to handle display automatically seems to cause this issue. Not starting the daemon on x start solved the issue. I had mons -m & in .xprofile, deleting it solved the issue.

Not the answer you're looking for? Browse other questions tagged or ask your own question.