2

My notebook is a Dell Inspiron 15 Gaming. My Ubuntu's version is xenial.

After upgrading from Ubuntu 14.04 to 16.04; the computer could not detect the sound card anymore... Also, alsamixer was not working neither...

I tried to do somethings: reinstall alsa utils; installed some drivers manually (oem-audio-hda-daily-Its-xenial-dkms).

Now the sound card is detected, the alsamixer works, when the computer starts it makes the initialization sound, but after I login there is no more sound...

When I open the sound configurations menu; there is nothing to choose as 'sound output', before, when the sound card was not detected, there was the option 'dummy output'.

I really don't know what to do anymore, it's the first time I am trying to use Linux in my PC, so I don't understand half of what people say in the forums where I am searching for an answer...


Okay... so I removed what I had installed and did what Tomás sugested below.

sudo add-apt-repository ppa:ubuntu-audio-dev/alsa-daily

sudo apt update

sudo aptitude --purge reinstall linux-sound-base alsa-base alsa-utils linux-image-`uname -r` linux-ubuntu-modules-`uname -r` libasound2

But nothing has changed


salmonsalt@salmonstation:~$ aplay -l
**** Lista de Dispositivos PLAYBACK Hardware ****
placa 0: PCH [HDA Intel PCH], dispositivo 0: ALC3246 Analog [ALC3246 Analog]
  Dispositivo secundário: 1/1
  Dispositivo secundário #0: subdevice #0
placa 0: PCH [HDA Intel PCH], dispositivo 3: HDMI 0 [HDMI 0]
  Dispositivo secundário: 1/1
  Dispositivo secundário #0: subdevice #0
placa 0: PCH [HDA Intel PCH], dispositivo 7: HDMI 1 [HDMI 1]
  Dispositivo secundário: 1/1
  Dispositivo secundário #0: subdevice #0
placa 0: PCH [HDA Intel PCH], dispositivo 8: HDMI 2 [HDMI 2]
  Dispositivo secundário: 1/1
  Dispositivo secundário #0: subdevice #0

(I am sorry, some words there are in Portuguese, I am Brazilian...)

aplay -D plughw:0 some_file.wav did work!

[solved!]

I reinstalled pulseaudio, but it did not solve it neither.

Finally, by creating a new user, the sound started working again!

2
+50
sudo add-apt-repository ppa:ubuntu-audio-dev/alsa-daily
sudo apt update

After updating alsa drivers, they will be reconfigured. I had the same problem, this solved it.

sudo aptitude --purge reinstall linux-sound-base alsa-base alsa-utils linux-image-`uname -r` linux-ubuntu-modules-`uname -r` libasound2

This will restore and reconfigure all sound drivers in ubuntu 16.04 to their default state. You may look whether proprietary drivers are enabled then.

As you said, you can try sudo apt install --reinstall pulseaudio pulseaudio-module-x11 and logout. If I can start with "it makes the initialization sound" again, it sounds definitely like user-related error. Consider making another user account to test whether the problem persists...

Another thing is, that your pulseaudio daemon may not start upon login.
Check System > Administration > BootUp Manager to make sure the service is activated.
The /etc/int.d/pulseaudio shell script should start the daemon, too.

  • It didn't work =/ – Daniel Cunha Jul 2 '17 at 15:13
  • 1
    edited the answer, hope it helps :) – Tomáš Pánik Jul 2 '17 at 15:51
  • It still does not work... I edited the post with current information! – Daniel Cunha Jul 2 '17 at 16:13
  • 1
    It works! I created a new user and now the sounds works again!! Thank you very much! – Daniel Cunha Jul 2 '17 at 17:18
  • I am happy to hear that! – Tomáš Pánik Jul 2 '17 at 17:44
1

Partial answer:

Quick walkthrough of the usual sound layers: The kernel drivers provide access to the hardware, ALSA provides a generalized API and library to access sound, and on top of that Pulseaudio uses ALSA to provide a more flexible transport mechanism for sound.

So we have to check all layers in turn to find out where the problem is. oem-audio-hda-daily-Its-xenial-dkms probably took care of the kernel driver. So do aplay -l to verify the sound card(s) are recognized, and edit your question with the output so we also know what soundcards you have.

Next, stop Pulseaudio (pulseaudio --kill) and verify that it has indeed stopped and is not respawning (ps axu shouldn't show a pulseaudio process anymore). Then do

aplay -D plughw:0 some_file.wav

where 0 is the number of the sound card you use, as seen in aplay -l.

If you can hear the WAV file playing, ALSA works, and we have to check what's wrong with Pulseaudio. If you can't hear it playing, check in alsamixer (don't forget to select your card with F6; the left and right arrow keys show more controls) that nothing is muted (MM instead of OO) that shouldn't be. If that doesn't help, do amixer -c0 contents (where 0 is again the number of your soundcard) and edit question with output, or put it into a pastebin etc. if it's very long.

Edit

Pulseaudio is usually run on a per-user basis, so creating a new user (after reinstalling etc.) probably set up this user's configuration files so that Pulseaudio now starts correctly.

If it should happen again (or someone else reads this), you can start Pulseaudio verbosely with

pulseaudio -v --start 

and it will log messages into syslog that should tell you what is going wrong.

  • I could hear the WAV with 'aplay', I edited the post with current information! – Daniel Cunha Jul 2 '17 at 16:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.