1

When I try to export the remote display I do:

In my Ubuntu 17.04:

xhost +
access control disabled, clients can connect from any host

Then I make the connection to the server:

ssh user@server

Once in the server get this error:

user@server:~$ export DISPLAY=my_ip:0.0
user@server:~$ xeyes
Error: Can't open display: my_ip:0.0

My gdm configuration is:

root@my_ip:/etc/gdm3# cat custom.conf

# GDM configuration storage
#
# See /usr/share/gdm/gdm.schemas for a list of available options.

[daemon]
# Uncoment the line below to force the login screen to use Xorg
#WaylandEnable=false

# Enabling automatic login
#  AutomaticLoginEnable = true
#  AutomaticLogin = user1

# Enabling timed login
#  TimedLoginEnable = true
#  TimedLogin = user1
#  TimedLoginDelay = 10

[security]
DisallowTCP=false

[xdmcp]
Enable=true
DisplaysPerHost=10 

[chooser]

[debug]
# Uncomment the line below to turn on debugging
# More verbose logs
# Additionally lets the X server dump core if it crashes
#Enable=true

GDM3 Version

gdm3 --version
GDM 3.24.0

netstat -puta

Conexiones activas de Internet (servidores y establecidos)
Proto  Recib Enviad Dirección local         Dirección remota       Estado       PID/Program name    
tcp        0      0 0.0.0.0:x11-1           0.0.0.0:*               ESCUCHAR    1477/Xorg           

ps fax | grep X

 1211 tty1     Sl+    0:01  |       \_ /usr/lib/xorg/Xorg vt1 -displayfd 3 -auth /run/user/120/gdm/Xauthority -background none -noreset -keeptty -verbose 3
 1477 tty2     Sl+    0:35          \_ /usr/lib/xorg/Xorg vt2 -displayfd 3 -auth /run/user/1000/gdm/Xauthority -listen tcp -background none -noreset -keeptty -verbose 3

tcpdump

11:41:20.065425 IP server.41874 > my_ip.x11: Flags [S], seq 1478700027, win 29200, options [mss 1460,sackOK,TS val 22197350 ecr 0,nop,wscale 7], length 0
11:41:20.065447 IP my_ip.x11 > server.41874: Flags [R.], seq 0, ack 1478700028, win 0, length 0
3

Solved. The problem was with my DISPLAY number. I supposed that my DISPLAY was 0.0 but :

xdpyinfo | grep display
name of display:    :1

So, the export DISPLAY must be:

export DISPLAY=my_ip:1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.