2

I am connecting a USB to Ethernet adapter to the USB2.0 port, this adapter is then connected to the ethernet cable and to the network switch. Now this shows up as the eth1 port on the ifconfig and I do get a dynamic IP address. my problem is,

1.Even if I modify the /etc/network/interfaces file to set the eth1 to static ip as below, the IP address is still dynamic.

    ##connman: WiFi
#
#connmanctl
#connmanctl> tether wifi off
#connmanctl> enable wifi
#connmanctl> scan wifi
#connmanctl> services
#connmanctl> agent on
#connmanctl> connect wifi_*_managed_psk
#connmanctl> quit

auto eth1
#allow-hotplug eth1
iface eth1 inet static
address 192.168.5.10
netmask 255.255.255.0
network 192.168.5.15
broadcast 192.168.5.255
gateway 192.168.5.1

# Ethernet/RNDIS gadget (g_ether)
# Used by: /opt/scripts/boot/autoconfigure_usb0.sh
iface usb0 inet static
    address 192.168.7.2
    netmask 255.255.0.0
    network 192.168.7.0
    gateway 192.168.7.1
  1. I believe the conman service is kicking in and reassigning the dynamic IP address to the board. I tried purging the connman service and it fixed the static IP address on eth0 but the eth1 interface stopped showing up.

    1. I re added the connman service and tried modifying the /usr/lib/connman/test/ but there is no connman folder under the usr/lib.

Any help is appreciated.

2

I solved it my creating a service for the manual connmanctl command

connmanctl config ethernet_20c9d029e088_cable ipv4 manual 192.168.5.10 255.255.255.0

Following are the steps 1. Create a bash script with above command. 2. Create a service to execute this script on boot up every time.

Creating the service instructions are below

http://mybeagleboneblackfindings.blogspot.com/2013/10/running-script-on-beaglebone-black-boot.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.