1

I have enabled quotas on an xfs-partition. But it seems to be broken:

$ echo asdf >/disk/l/data/avi/foo
-su: /disk/l/data/avi/foo: Disk quota exceeded

$ quota -f /disk/l
Disk quotas for user avi (uid x): 
 Filesystem  blocks   quota   limit   grace   files   quota   limit   grace
 /dev/md0 1801035344  3000000000 4000000000           38063       0       0 

Any ideas why?

Edit:

grpquotas explained the problem for some users, but I still have users quota issues for other users.

$ touch a
touch: cannot touch `a': Disk quota exceeded
$ quota -f .
Disk quotas for user s (uid 2267): 
 Filesystem  blocks   quota   limit   grace   files   quota   limit   grace
   /dev/md0  293812  1000000000 2000000000               8       0       0
$ mount
/dev/md0 on /disk/l type xfs (rw,usrquota,grpquota)
# xfs_quota -x -c report |grep -v -- '------'
User quota on /disk/l (/dev/md0)
                           Blocks                     
User ID          Used       Soft       Hard    Warn/Grace     

Group quota on /disk/l (/dev/md0)
                           Blocks                     
Group ID         Used       Soft       Hard    Warn/Grace     
[... i.e. no groups or users over their soft limit ...]
1

It's possible that you need to use xfs_quota(8) for XFS filesystems.

Alternatively, the -F xfs option may be necessary to quota, if format autodetection isn't deducing it correctly.

If neither of these are useful, can you indicate how you enabled quotas, and how you mounted this filesystem?

1

The problem was group quotas. The user quota was not exceeded, but the group quota was.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.