0

I'm running Arch Linux. In dmesg I have the following messages:

[    3.225860] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[    8.405807] e1000e: eth0 NIC Link is Down
[   39.495793] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   44.679494] e1000e: eth0 NIC Link is Down
[  110.525785] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[  115.709482] e1000e: eth0 NIC Link is Down
[  344.245735] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready

I am indeed using IPv6 on this link (it connects to a cable modem) and I do need this link to become ready. Notice that the "not ready" isn't a brief passing issue. It does not become ready at all until I bring it up manually.

I had to replace the motherboard after a lightning strike. After doing this, the eth0 (the one on the motherboard) does not come up automatically, but the 4 ports on the Intel PCI card (Ethernet Server Adapter I340-T4) do come up. The motherboard features an Intel Ethernet (I219-V). (See lspci output below.)

I tried the following without success:

netctl reenable eth0-profile

This link still fails to come up automatically. ip a shows this link is DOWN. netctl status shows a failure:

netctl status eth0-profile
● netctl@eth0\x2dprofile.service - WAN
Loaded: loaded (/etc/systemd/system/netctl@eth0\x2dprofile.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Wed 2017-06-28 02:14:27 EDT; 11min ago
    Docs: man:netctl.profile(5)
Process: 329 ExecStart=/usr/lib/network/network start %I (code=exited, status=1/FAILURE)
Main PID: 329 (code=exited, status=1/FAILURE)

Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.

Running this next command manually does not give success:

netctl start eth0-profile

This system has never had an enabled a systemd unit for dhcpcd@eth0.service (or even a generic all-interfaces dhcpcd service). I'm not against adding one if that will fix it, but it worked before without it and I'd like to get back to the prior state. (I have btrfs snapshots, but I don't want to roll back. I want to understand what is going on and make the corrections so I learn something from this.)

To resolve my link problem, I have to run the following commands.

sudo ip link set eth0 up
sudo dhcpcd -n eth0
sudo systemctl restart dnsmasq

Once I run these commands, everything is fine. For some reason, it just isn't starting automatically. When running these commands, I notice that ip link set eth0 up takes a long time. Sometimes I have to run it multiple times.

UPDATE 1

/etc/netctl/eth0-profile:

Description='WAN'
Interface=eth0
Connection=ethernetvpn
IP='dhcp'

lspci -v

00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (2) I219-V (rev 31)
        Subsystem: ASUSTeK Computer Inc. Device 8672
        Flags: bus master, fast devsel, latency 0, IRQ 143
        Memory at f7400000 (32-bit, non-prefetchable) [size=128K]
        Capabilities: [c8] Power Management version 3
        Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [e0] PCI Advanced Features
        Kernel driver in use: e1000e
        Kernel modules: e1000e

01:00.0 Ethernet controller: Intel Corporation 82580 Gigabit Network Connection (rev 01)
        Subsystem: Intel Corporation Ethernet Server Adapter I340-T4
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at f7180000 (32-bit, non-prefetchable) [size=512K]
        Memory at f720c000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: [40] Power Management version 3
        Capabilities: [50] MSI: Enable- Count=1/1 Maskable+ 64bit+
        Capabilities: [70] MSI-X: Enable+ Count=10 Masked-
        Capabilities: [a0] Express Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Device Serial Number 00-1b-2c-3d-4e-5f-6a-7b
        Capabilities: [1a0] Transaction Processing Hints
        Capabilities: [1c0] Latency Tolerance Reporting
        Kernel driver in use: igb
        Kernel modules: igb

01:00.1 Ethernet controller: Intel Corporation 82580 Gigabit Network Connection (rev 01)
        Subsystem: Intel Corporation Ethernet Server Adapter I340-T4
        Flags: bus master, fast devsel, latency 0, IRQ 17
        Memory at f7100000 (32-bit, non-prefetchable) [size=512K]
        Memory at f7208000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: [40] Power Management version 3
        Capabilities: [50] MSI: Enable- Count=1/1 Maskable+ 64bit+
        Capabilities: [70] MSI-X: Enable+ Count=10 Masked-
        Capabilities: [a0] Express Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Device Serial Number 00-1b-2c-3d-4e-5f-6a-7b
        Capabilities: [1a0] Transaction Processing Hints
        Kernel driver in use: igb
        Kernel modules: igb

01:00.2 Ethernet controller: Intel Corporation 82580 Gigabit Network Connection (rev 01)
        Subsystem: Intel Corporation Ethernet Server Adapter I340-T4
        Flags: bus master, fast devsel, latency 0, IRQ 18
        Memory at f7080000 (32-bit, non-prefetchable) [size=512K]
        Memory at f7204000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: [40] Power Management version 3
        Capabilities: [50] MSI: Enable- Count=1/1 Maskable+ 64bit+
        Capabilities: [70] MSI-X: Enable+ Count=10 Masked-
        Capabilities: [a0] Express Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Device Serial Number 00-1b-2c-3d-4e-5f-6a-7b
        Capabilities: [1a0] Transaction Processing Hints
        Kernel driver in use: igb
        Kernel modules: igb

01:00.3 Ethernet controller: Intel Corporation 82580 Gigabit Network Connection (rev 01)
        Subsystem: Intel Corporation Ethernet Server Adapter I340-T4
        Flags: bus master, fast devsel, latency 0, IRQ 19
        Memory at f7000000 (32-bit, non-prefetchable) [size=512K]
        Memory at f7200000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: [40] Power Management version 3
        Capabilities: [50] MSI: Enable- Count=1/1 Maskable+ 64bit+
        Capabilities: [70] MSI-X: Enable+ Count=10 Masked-
        Capabilities: [a0] Express Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Device Serial Number 00-1b-2c-3d-4e-5f-6a-7b
        Capabilities: [1a0] Transaction Processing Hints
        Kernel driver in use: igb
        Kernel modules: igb

UPDATE 2

I still have not found a solution. Adding these two lines to the /etc/netctl/eth0-profile seemed to resolve it for a while, but the problem has returned.

TimeoutUp=300
TimeoutCarrier=300

I have found some new information. After the most recent boot, the logs showed these issues:

Sep 12 03:38:26 arch2 network[358]: Duplicate Address Detection is taking too long on interface 'eth0'
Sep 12 03:38:27 arch2 network[358]: Failed to bring the network up for profile 'eth0-profile'
Sep 12 03:38:27 arch2 dhcpcd[588]: script_runreason: /usr/lib/dhcpcd/dhcpcd-run-hooks: Terminated

I can bring the network up like this:

# netctl restart eth0-profile

after that, everything is working. However, I'd like to find and resolve the underlying issue.

Here is output of systemctl status "netctl@eth0\x2dprofile.service"

● netctl@eth0\x2dprofile.service - ETH0
Loaded: loaded (/etc/systemd/system/netctl@eth0\x2dprofile.service; enabled; vendor preset: disabled)
Active: active (exited) since Tue 2017-09-12 03:47:54 EDT; 36s ago
    Docs: man:netctl.profile(5)
Process: 870 ExecStart=/usr/lib/netctl/network start eth0-profile (code=exited, status=0/SUCCESS)
Main PID: 870 (code=exited, status=0/SUCCESS)
Status: "online"
    Tasks: 2 (limit: 4915)
CGroup: /system.slice/system-netctl.slice/netctl@eth0\x2dprofile.service
        ├─ 963 dhcpcd -4 -q -t 30 -L eth0
        └─1070 dhcpcd -6 -q -t 30 eth0

Sep 12 03:47:59 arch2 dhcpcd[1050]: eth0: soliciting an IPv6 router
Sep 12 03:47:59 arch2 dhcpcd[1050]: eth0: Router Advertisement from ff00::bbda:ffff:fe44:2dee
Sep 12 03:47:59 arch2 dhcpcd[1050]: eth0: adding address 2001:333:300:1c6:dd09:189b:cf5b:bbbb/64
Sep 12 03:47:59 arch2 dhcpcd[1050]: eth0: adding route to 2601:343:380:1f6::/64
Sep 12 03:47:59 arch2 dhcpcd[1050]: eth0: adding default route via ff00::bbda:ffff:fe44:2dee
Sep 12 03:47:59 arch2 dhcpcd[1050]: forked to background, child pid 1070
Sep 12 03:47:59 arch2 dhcpcd[1070]: eth0: confirming prior DHCPv6 lease
Sep 12 03:47:59 arch2 network[870]: Started network profile 'eth0-profile'
Sep 12 03:48:09 arch2 dhcpcd[1070]: eth0: failed to confirm prior address
Sep 12 03:48:09 arch2 dhcpcd[1070]: eth0: soliciting a DHCPv6 lease
  • Can you show your profile configuration please? – Daniel Jun 28 '17 at 11:16
  • @Daniel thanks for your interest. Added that info to the question. – MountainX Jun 28 '17 at 13:03
0

My solution was fairly simple. I added these two lines to the /etc/netctl/eth0-profile:

TimeoutUp=300
TimeoutCarrier=300
  • turns out the issue is not solved – MountainX Sep 12 '17 at 8:53
0

My solution was to add the following line to the netctl profile (in /etc/netctl) for this interface:

SkipDAD=yes

The system boots faster than ever now, and the errors are all resolved.

This is one box that connects by one ethernet cable directly to a cable modem. That's the entire network and there will never be other systems connected. So DAD was not serving any useful purpose, afaik. But it was causing real problems. Skipping DAD makes sense to me, although I'm sure someone will say this is the wrong solution. It is the best solution I have found in the last 3 months, and it results in a system that boots up better than it ever has.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.