4

Recently, I've setup a FreeBSD 11 on a 6GB PATA 2.5" hard drive using a PATA/SATA>USB adapter and qemu on my main Arch Linux computer. FreeBSD boots OK in qemu, but when moved to my Dell Latitude XPi (P133, 56mb RAM) it loads the bootstrap loader and then says:

Can't work out which disk we are booting from.
Guessed BIOS device 0xffffffff not found by probes, defaulting to disk0:

can't load 'kernel'

Type '?' for a list of commands, 'help' for more detailed help.
OK

After using lsdev for listing devices, I'm getting:

cd devices:
disk devices:
      disk0:  BIOS drive a:
      disk1:  BIOS drive c:
pxe devices:

I'm seeing that bootstrap tries to load kernel of a non-existing floppy drive rather than HDD; I've tried boot disk1:boot/bootX, where X is a number (there are several binary files labeled boot and a number in /boot/, at least on the iso), but it returns can't find 'disk1:boot/bootX

migrated from retrocomputing.stackexchange.com Jun 27 '17 at 21:16

This question came from our site for vintage-computer hobbyists interested in restoring, preserving, and using the classic computer and gaming systems of yesteryear.

  • Try using set currdev=disk1s0 or maybe set currdev=disk0s0 and then entering boot or boot /boot/kernel/kernel. – Ross Ridge Jun 28 '17 at 23:17
0

1:ad(1,a) enter at the boot2 prompt

or read man boot, man boot.config man loader etc... Hope that helps somehow. Good luck

  • It returns error 1 lba 0 without a newline, and then complains about No /boot/loader. Entering 0:ad(X,a) sends me to the screen i've already listed in the question. – redsPL Jun 28 '17 at 7:44
0

The old FreeBSD bootloader ("boot1") worked with the BIOS to find and parse the root partition in order to find the loader. This requires the proper configuration of Cylinder/Heads/Sectors to match the physical geometry of the IDE drive. This was super annoying as the BIOS lied to fdisk sometimes during install. This went away later when LBA addressing was supported by BIOSes.

First try to enable LBA mode: http://phaq.phunsites.net/2007/05/25/freebsds-loader-fails-with-wrong-harddisk-geometry-in-bios/

Gory internals: https://www.freebsd.org/doc/en/books/arch-handbook/book.html#boot-boot1

  • It is encouraged that you provide link content in your answer, so that your answer will still be valid if the link becomes invalid. – John Militer Jul 10 '17 at 21:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.