0

So I have a MFC-J265W Brother printer (connected via USB) and got it to print under Debian 9.0 64bit. For this I had to select my model on the Brother homepage and install the Driver Install Tool by following their instructions on the site.

However when I try to scan with Simple Scan I get:

Failed to scan
No scanners available. Please connect a scanner.

and when I close that message it shows:

Additional software needed
You need to install driver software for your scanner.


I also tried installing "Scanner driver 64bit" separately which didn't help.
And after all of that I also tried to install the 32bit Scanner driver and Scan-key-tool even though I have a 64bit machine. When installing the 32bit Scan-key-tool I get: brscan-skey:i386 depends on libc6 (>= 2.3.4-1) even though I have the latest libc6 and libc6-i386 installed. I also tried un/reinstalling.
In addition I also tried gscan2pdf instead of Simple Scan which shows me "No devices found".

After proper (64bit) installation dpkg -l | grep Brother shows me:

ii  brscan-skey                                                      0.2.4-1                              amd64        Brother Linux scanner S-KEY tool
ii  brscan3                                                          0.2.13-1                             amd64        Brother Scanner Driver
ii  mfcj265wcupswrapper:i386                                      1.1.3-1                              i386         Brother CUPS Inkjet Printer Definitions
ii  mfcj265wlpr:i386                                              1.1.3-1                              i386         Brother lpr Inkjet Printer Definitions

Note that printing works like a charm and iirc for that I didn't have to do the following; however:

I also enabled 32bit architecture by running sudo dpkg --add-architecture i386.
After doing so (not in the instructions) the installation runs through without any error except:

mkdir: cannot create directory ‘/var/spool/lpd/printername’: No such file or directory
chown: cannot access '/var/spool/lpd/printername': No such file or directory

which I also fixed by creating the directories manually using the mkdir command.

  • To start with, please edit your question to mention your model, please.Also, the link to the driver. And the documentation you used to install it. If you are trying to use the proprietary Brother driver, that's usually straight forward, I think. But you do have to do a minimal amount of configuration. – Faheem Mitha Jun 27 '17 at 21:27
  • @FaheemMitha Alright I just added the model name and its link. The documentation is shown when you download the "Driver Install Tool" or scanner driver. Well I thought that too but apparently that's not the case. – mYnDstrEAm Jun 27 '17 at 21:38
  • Ok. Well, if you have a 64 bit machine, install the 64 bit Debian package, not the 32 bit one. – Faheem Mitha Jun 27 '17 at 21:49
  • 1
    Have you used the Driver Install Tool from here dated 11/25/2016 and/or the scanner setting file of the same date? – Arrow Jun 28 '17 at 0:20
  • 1
    Is this the how to you are following? – Arrow Jun 28 '17 at 2:22
1

So User Arrow helped me solve it by recommending this guide. I executed these commands to get it to work with my 64bit machine:

sudo ln -sf /usr/lib64/libbrscandec*.so* /usr/lib

sudo mkdir -p /usr/lib/sane

sudo ln -sf /usr/lib64/sane/libsane-brother*.so* /usr/lib/sane

sudo usermod -a -G scanner username

gksudo simple-scan

This is not in the instructions on the Brother-site.

Before issuing these commands I installed the Driver Install Tool and made sure the installation runs through without an error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.