4

we have an embedded PC with an Linux OS which seems to be an Debian/Ubuntu derivate with RT-Preempt patch.

At this pc we attached a display (7" 1024x600 170 DPI) via DVI. We are need to run the output in portrait and only basic X11 (not a complete graphical shell with window manager and further).

Regarding the CLI-Mode it is only a minor change in /etc/default/grub. For X11 I don't get it work correctly.

Using startx leads to an smaller terminal than full size in landscape mode. So I try:

xrandr --output HDMI0 --rotate left --mode 1028x600 -- dpi 170

Now the orientation is correct, but the terminal area is only a third of the display. And running xrandr tells me Screen 0: minimum 320 x 200, current 800 x 600, maximum 8192 x 8192.

How to set up the display correctly, so that:

  • X starts in portrait mode
  • on the correct resolution and size
  • the configuration affects all users
  • with the minimal (installation) effort

Thanks


Using /etc/X11/xorg.conf

Thanks for your reply. I try the way using /etc/X11/xorg.conf (the configuration file doesn't exist before) with the following content:

# modelines generated by using: http://xtiming.sourceforge.net/cgi-bin/xtiming.pl

Section "Monitor"
        Identifier   "IntegratedDisplay0"
        VendorName   "LITEMAX"
        ModelName    "DLH0765-ENN-G02"
        Option       "Rotate" "left"
        Modeline     "1024x600" 48.11 1024 1056 1232 1264 600 612 618 631
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "IntegratedDisplay0"
        SubSection "Display"
                Viewport   0 0
                Depth    24
                Modes "1024x600"
        EndSubSection
EndSection

Because the resolution seems to be unusual I define a modeline. Somewhere I found the information that xrandr can only set to given modes.

After running startx from one user the output is rotated correctly but there are two things left:

  1. Then I go around with the mouse pointer (cross) it can be determined that a half cross is visible on the upper, the left, the lower and the lower half of the right border. On the upper right border the mouse seems to have more 'size' to the right.

  2. That is the output of xrandr:

    Screen 0: minimum 320 x 200, current 800 x 1024, maximum 8192 x 8192
    HDMI1 connected 600x1024+0+0 left (normal left inverted right x axis y axis) 153mm x 90mm
       1024x600      60.01*+  60.32
       800x600       60.32  
    DP1 disconnected (normal left inverted right x axis y axis)
    HDMI2 disconnected (normal left inverted right x axis y axis)
    DP2 connected 800x600+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
       1024x768      60.00  
       800x600       60.32*   56.25  
       848x480       60.00  
       640x480       59.94 
    

    This looks like as the display is using the wrong resolution. How can I correct this issue? Beside: The connection is an DVI and not a HDMI as shown by xrandr.

2
  • You need to run xrandr -q and choose resolution from list. To make X server start with this resolution and orientation you need to set Modes for Display subsection of your Screen and Rotate option in Monitor section. Check man xorg.conf – user996142 Jun 27 '17 at 18:08
  • 3
    PS: Here is part of my xorg.conf I use to start X with 800x600 and rotated monitor (pastebin.com/GpqQKtBZ) – user996142 Jun 27 '17 at 18:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.