3

I am attempting to install Zabbix 3.2 on Centos7 running PHP7.

Link to the walkthrough

The command:

yum -y install zabbix-get zabbix-server-mysql zabbix-web-mysql zabbix-agent

The output:

Loaded plugins: fastestmirror, langpacks, replace
Loading mirror speeds from cached hostfile
 * base: mirror.us-midwest-1.nexcess.net
 * epel: mirror.steadfast.net
 * extras: mirror.millry.co
 * ius: dfw.mirror.rackspace.com
 * updates: repos-va.psychz.net
Resolving Dependencies
--> Running transaction check
---> Package zabbix-agent.x86_64 0:3.2.6-1.el7 will be installed
---> Package zabbix-get.x86_64 0:3.0.9-1.el7 will be updated
---> Package zabbix-get.x86_64 0:3.2.6-1.el7 will be an update
---> Package zabbix-server-mysql.x86_64 0:3.2.6-1.el7 will be installed
---> Package zabbix-web-mysql.noarch 0:3.2.6-1.el7 will be installed
--> Processing Dependency: zabbix-web = 3.2.6-1.el7 for package: zabbix-web-mysql-3.2.6-1.el7.noarch
--> Processing Dependency: php-mysql for package: zabbix-web-mysql-3.2.6-1.el7.noarch
--> Running transaction check
---> Package php56u-mysqlnd.x86_64 0:5.6.30-2.ius.centos7 will be installed
--> Processing Dependency: php56u-pdo(x86-64) = 5.6.30-2.ius.centos7 for package: php56u-mysqlnd-5.6.30-2.ius.centos7.x86_64
---> Package zabbix-web.noarch 0:3.2.6-1.el7 will be installed
--> Processing Dependency: php-gd for package: zabbix-web-3.2.6-1.el7.noarch
--> Processing Dependency: php-bcmath for package: zabbix-web-3.2.6-1.el7.noarch
--> Processing Dependency: php-ldap for package: zabbix-web-3.2.6-1.el7.noarch
--> Running transaction check
---> Package php56u-pdo.x86_64 0:5.6.30-2.ius.centos7 will be installed
--> Processing Dependency: php56u-common(x86-64) = 5.6.30-2.ius.centos7 for package: php56u-pdo-5.6.30-2.ius.centos7.x86_64
---> Package php71u-bcmath.x86_64 0:7.1.6-1.ius.centos7 will be installed
--> Processing Dependency: php-common(x86-64) = 7.1.6-1.ius.centos7 for package: php71u-bcmath-7.1.6-1.ius.centos7.x86_64
---> Package php71u-gd.x86_64 0:7.1.6-1.ius.centos7 will be installed
---> Package php71u-ldap.x86_64 0:7.1.6-1.ius.centos7 will be installed
--> Running transaction check
---> Package php56u-common.x86_64 0:5.6.30-2.ius.centos7 will be installed
--> Processing Dependency: php56u-pecl-jsonc(x86-64) for package: php56u-common-5.6.30-2.ius.centos7.x86_64
---> Package php71u-common.x86_64 0:7.1.6-1.ius.centos7 will be installed
--> Running transaction check
---> Package php56u-pecl-jsonc.x86_64 0:1.3.10-2.ius.centos7 will be installed
--> Processing Dependency: php56u-pear for package: php56u-pecl-jsonc-1.3.10-2.ius.centos7.x86_64
--> Processing Dependency: php56u-pear for package: php56u-pecl-jsonc-1.3.10-2.ius.centos7.x86_64
--> Running transaction check
---> Package php56u-pear.noarch 1:1.10.4-1.ius.centos7 will be installed
--> Processing Dependency: php56u-cli for package: 1:php56u-pear-1.10.4-1.ius.centos7.noarch
--> Processing Dependency: php56u-posix for package: 1:php56u-pear-1.10.4-1.ius.centos7.noarch
--> Processing Dependency: php56u-xml for package: 1:php56u-pear-1.10.4-1.ius.centos7.noarch
--> Running transaction check
---> Package php56u-cli.x86_64 0:5.6.30-2.ius.centos7 will be installed
---> Package php56u-process.x86_64 0:5.6.30-2.ius.centos7 will be installed
---> Package php56u-xml.x86_64 0:5.6.30-2.ius.centos7 will be installed
--> Processing Conflict: php70u-cli-7.0.19-1.ius.centos7.x86_64 conflicts php-cli < 7.0.19
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package php70u-cli.x86_64 0:7.0.19-1.ius.centos7 will be updated
---> Package php70u-cli.x86_64 0:7.0.20-1.ius.centos7 will be an update
--> Processing Dependency: php-common(x86-64) = 7.0.20-1.ius.centos7 for package: php70u-cli-7.0.20-1.ius.centos7.x86_64
--> Running transaction check
---> Package php70u-common.x86_64 0:7.0.19-1.ius.centos7 will be updated
--> Processing Dependency: php-common(x86-64) = 7.0.19-1.ius.centos7 for package: mod_php70u-7.0.19-1.ius.centos7.x86_64
--> Processing Dependency: php-common(x86-64) = 7.0.19-1.ius.centos7 for package: php70u-mbstring-7.0.19-1.ius.centos7.x86_64
--> Processing Dependency: php-common(x86-64) = 7.0.19-1.ius.centos7 for package: php70u-mcrypt-7.0.19-1.ius.centos7.x86_64
--> Processing Dependency: php-common(x86-64) = 7.0.19-1.ius.centos7 for package: php70u-pdo-7.0.19-1.ius.centos7.x86_64
--> Processing Dependency: php-common(x86-64) = 7.0.19-1.ius.centos7 for package: php70u-xml-7.0.19-1.ius.centos7.x86_64
--> Processing Dependency: php-common(x86-64) = 7.0.19-1.ius.centos7 for package: php70u-json-7.0.19-1.ius.centos7.x86_64
---> Package php70u-common.x86_64 0:7.0.20-1.ius.centos7 will be an update
--> Running transaction check
---> Package mod_php70u.x86_64 0:7.0.19-1.ius.centos7 will be updated
---> Package mod_php70u.x86_64 0:7.0.20-1.ius.centos7 will be an update
---> Package php70u-json.x86_64 0:7.0.19-1.ius.centos7 will be updated
---> Package php70u-json.x86_64 0:7.0.20-1.ius.centos7 will be an update
---> Package php70u-mbstring.x86_64 0:7.0.19-1.ius.centos7 will be updated
---> Package php70u-mbstring.x86_64 0:7.0.20-1.ius.centos7 will be an update
---> Package php70u-mcrypt.x86_64 0:7.0.19-1.ius.centos7 will be updated
---> Package php70u-mcrypt.x86_64 0:7.0.20-1.ius.centos7 will be an update
---> Package php70u-pdo.x86_64 0:7.0.19-1.ius.centos7 will be updated
--> Processing Dependency: php-pdo(x86-64) = 7.0.19-1.ius.centos7 for package: php70u-mysqlnd-7.0.19-1.ius.centos7.x86_64
---> Package php70u-pdo.x86_64 0:7.0.20-1.ius.centos7 will be an update
---> Package php70u-xml.x86_64 0:7.0.19-1.ius.centos7 will be updated
---> Package php70u-xml.x86_64 0:7.0.20-1.ius.centos7 will be an update
--> Running transaction check
---> Package php70u-mysqlnd.x86_64 0:7.0.19-1.ius.centos7 will be updated
---> Package php70u-mysqlnd.x86_64 0:7.0.20-1.ius.centos7 will be an update
--> Processing Conflict: php71u-common-7.1.6-1.ius.centos7.x86_64 conflicts php-common < 7.1.6-1.ius.centos7
--> Processing Conflict: php71u-common-7.1.6-1.ius.centos7.x86_64 conflicts php-common < 7.1.6-1.ius.centos7
--> Processing Conflict: php71u-common-7.1.6-1.ius.centos7.x86_64 conflicts php56u-common
--> Processing Conflict: php71u-common-7.1.6-1.ius.centos7.x86_64 conflicts php70u-common
--> Processing Conflict: php70u-common-7.0.20-1.ius.centos7.x86_64 conflicts php-common < 7.0.20
--> Processing Conflict: php70u-common-7.0.20-1.ius.centos7.x86_64 conflicts php56u-common
--> Processing Conflict: php70u-cli-7.0.20-1.ius.centos7.x86_64 conflicts php-cli < 7.0.20
--> Processing Conflict: php70u-json-7.0.20-1.ius.centos7.x86_64 conflicts php-json < 7.0.20
--> Processing Conflict: php70u-mysqlnd-7.0.20-1.ius.centos7.x86_64 conflicts php-mysql < 7.0.20
--> Processing Conflict: php70u-mysqlnd-7.0.20-1.ius.centos7.x86_64 conflicts php-mysqlnd < 7.0.20
--> Processing Conflict: php70u-pdo-7.0.20-1.ius.centos7.x86_64 conflicts php-pdo < 7.0.20
--> Processing Conflict: php70u-xml-7.0.20-1.ius.centos7.x86_64 conflicts php-xml < 7.0.20
--> Finished Dependency Resolution
Error: php71u-common conflicts with php56u-common-5.6.30-2.ius.centos7.x86_64
Error: php70u-xml conflicts with php56u-xml-5.6.30-2.ius.centos7.x86_64
Error: php71u-common conflicts with php70u-common-7.0.20-1.ius.centos7.x86_64
Error: php70u-mysqlnd conflicts with php56u-mysqlnd-5.6.30-2.ius.centos7.x86_64
Error: php70u-cli conflicts with php56u-cli-5.6.30-2.ius.centos7.x86_64
Error: php70u-pdo conflicts with php56u-pdo-5.6.30-2.ius.centos7.x86_64
Error: php70u-common conflicts with php56u-common-5.6.30-2.ius.centos7.x86_64
Error: php70u-json conflicts with php56u-pecl-jsonc-1.3.10-2.ius.centos7.x86_64

Attempted to fix using yum-plugin-replace commands

For example:

yum replace php56u-common --replace-with php71u-common

got this output:

Loaded plugins: fastestmirror, langpacks, replace
Replacing packages takes time, please be patient...
Error: Package 'php56u-common' is not installed.

also tried (per this link):

yum replace php-common --replace-with php71u-common

and got this output:

Loaded plugins: fastestmirror, langpacks, replace
Replacing packages takes time, please be patient...
Error: Package 'php-common' is not installed

I noticed these php56 packages were not installed when doing a yum list installed, but do show up when doing a yum list available.

Any insight on how to fix this is appreciated.

3
  • Most package managers do not allow concurrent versions. So if you need to install this package which requires PHP 7, you would have to uninstall the previous version and all its direct dependencies. Commented Jun 27, 2017 at 16:01
  • 1
    As stated in the description, anything php 5.6 related does not show as installed, but does show as available, that was the first thing I checked. Commented Jun 27, 2017 at 16:37
  • There is obviously a conflict so lets take a look at yum list installed php*. Commented Jun 28, 2017 at 4:54

1 Answer 1

0

Try this:

remove all PHP packages

yum remove php*

Install PHP 7.1 packages:

yum install php71u php71u-cli php71u-common php71u-gd php71u-mbstring php71u-mysqlnd php71u-pdo php71u-xml php71u-json

You are done, Check the vresion now php -v

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .