1

I have a RHEL 7 that has connectivity to the internet and no proxy in between. I can ping 8.8.8.8 I am trying to install grafana (an application for dashboards) based on official docs: http://docs.grafana.org/installation/rpm/

I am unable to do a yum install for this:

 sudo yum install https://s3-us-west-2.amazonaws.com/grafana-releases/release/grafana-4.3.1-1.x86_64.rpm

I get the following error:

Loaded plugins: fastestmirror
Cannot open: https://s3-us-west-2.amazonaws.com/grafana-releases/release/grafana-4.3.1-1.x86_64.rpm. Skipping.
Error: Nothing to do

If I follow these instructions:

 wget https://s3-us-west-2.amazonaws.com/grafana-releases/release/grafana-4.3.1-1.x86_64.rpm
$ sudo yum install initscripts fontconfig
$ sudo rpm -Uvh grafana-4.3.1-1.x86_64.rpm

I can download the rpm, but I once again get stuck at line #2 - yum install Am I missing something? I've previously installed other packages using yum on the same machine and it worked fine.

  • It is possible that yum is using ipv6 to try to connect to the internet, but you have configuration issues with said ipv6. Try ping6 google.com and add the results to your question. – KevinO Jun 27 '17 at 16:22
0

I tried to install grafana package on my Lab and it is installed successfully by using

yum install https://s3-us-west-2.amazonaws.com/grafana-releases/release/grafana-4.3.1-1.x86_64.rpm

So maybe the problem with your internet speed ?? tell me what is your connection speed and is it stable connection ??

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.