1

I'm using cups-pdf to print via lpd (Port 515) That's working so far, but all pdf-files are created with its content of the printer configuration. The PDF file includes following:

Media Limits: 0.00 x 0.00 to 8.26 x 11.69 inches
Job ID: PDFPrinter003-197
Driver: CUPS-PDF.PPD
Driver Version: 1.1
Description: SAP2PDF
Driver Version: SAP2PDF
Make and Model: Generic CUPS-PDF Printer (no options)
Printer: PDFPrinter003
Created at: Tue Jun 27 12:42:12 2017
Printed at: Tue Jun 27 12:42:12 2017

I can't find anything interesting in the log files. In /var/log/cups/cups-pdf-PDFPrinter003_log is everything fine about the PDF Creation.

In /var/log/cups/error_log is the following:

W [27/Jun/2017:13:00:11 +0200] CreateProfile failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
W [27/Jun/2017:13:00:11 +0200] CreateProfile failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
W [27/Jun/2017:13:00:11 +0200] CreateDevice failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
W [27/Jun/2017:13:00:38 +0200] CreateProfile failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
W [27/Jun/2017:13:00:38 +0200] CreateProfile failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
W [27/Jun/2017:13:00:38 +0200] CreateDevice failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
W [27/Jun/2017:13:00:46 +0200] Unexpected 'document-format' operation attribute in a Create-Job request.
W [27/Jun/2017:13:00:46 +0200] Unexpected 'document-name' operation attribute in a Create-Job request.

My xinetd.conf part for lpd-printing is the following:

service printer
    {
        socket_type = stream
        protocol = tcp
        wait = no
        user = lp
        server = /usr/lib/cups/daemon/cups-lpd
    }

Please ask if something is missing.

Do you have an idea?

Greetz Eldo.O

1

Solved:

it was a "feature" in lpd. By default, lpd prints a "banner" and creates 2 spool-files. The first spool file has been printet, but it's only the banner and the second file was ignored by cups-pdf.

I had to disable the banner in the xinetd.conf

server_args = -o document-format=application/octet-stream -o job-sheets=none,none

That solved my problem.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.