1

When using ifdown or ifup for the lookback interface in CentOS 7:

[root@localhost etc]# ifup lo

I have got the error below:

Could not load file '/etc/sysconfig/network-scripts/ifcfg-lo'
Could not load file '/etc/sysconfig/network-scripts/ifcfg-lo'
Could not load file '/etc/sysconfig/network-scripts/ifcfg-lo'
Could not load file '/etc/sysconfig/network-scripts/ifcfg-lo'

However if I use the ifconfig command, it shows the command(ifdown or ifup) works with success.


As I tested, the use of the ifconfig lo up/down does not show any signs of errors.

What is happening?


EDIT

I checked the ifcfg-lo file, it shows the info below:

[root@localhost etc]# ls -la /etc/sysconfig/network-scripts/ifcfg-lo
-rw-r--r--. 1 root root 254 Jun 26 20:07 /etc/sysconfig/network-scripts/ifcfg-lo
  • ifconfig does not use network-scripts ; please edit the question and add to it the output of ls -la /etc/sysconfig/network-scripts/ifcfg-lo – Rui F Ribeiro Jun 26 '17 at 12:41
  • Does chmod a+rx /etc/sysconfig/network-scripts/ifcfg-lo correct the situation? (probably not, I suspect it must be something with selinux...) – Rui F Ribeiro Jun 26 '17 at 13:01
  • @RuiFRibeiro it still reports the error. and in the front, I tells it even reports the mentioned error but the command works. – three-blocks Jun 26 '17 at 13:06
  • Or the command appears to work. I am sure, I do not use selinux, someone else will hopefully help you. – Rui F Ribeiro Jun 26 '17 at 13:08
1

First of all stop Using ifconfig command anymore with Centos 7 version and later versions because it doesnt give you full information about your network card parameters (For example if you assigened 2 IP addresses to your Card) instead use ipa command or ip addr show command. Second This problem is currently being tracked as a bug by Red Hat. To Fix this problem: Add NM_CONTROLLED=no to /etc/sysconfig/network-scripts/ifcfg-lo. Root Cause: ifcfg-rh plugin in NetworkManager does not support loopback interface type and logs a message about it in system log.

0

If you want to fully resolve this issues, update to higher version. And in current version you can fix it by adding "NM_CONTROLLED=no" to /etc/sysconfig/network-scripts/ifcfg-lo configuration file, then restart the network following this link https://access.redhat.com/solutions/1549693

  • 1
    Please add some details from the external webpage in your answer, using the page as a reference rather than the primary resource. – Munir Jan 5 '18 at 3:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.