Hi I cloned my dual boot computer with ubuntu 16.04 and windows 10 on it. I used this clone on a different model computer. I know this is definitely not best practice. It would not boot but i fixed this with grub repair tool. Everything works except the wifi card is not recognized (Ethernet is recognized). The computer is a Lenovo T470.

Before I cloned I have verified that the wifi card worked perfectly with same version of Ubuntu installed on it. Wifi card definitely works as it works in windows.

Things ive tried to fix this: - function key (F8 in this case)

  • updating drivers in additional drivers in system settings

  • extracting .inf files from windows and using ndiswrapper with the windows driver

  • Installed and ran backports

  • Used synaptic package manager to update all under the networking tab

  • BIOS has secure boot disabled and networking for ethernet and wifi is enabled.

If you need any information or logs please let me know.

Would appreciate any ideas.


Thanks for the Idea ChristophS but this file was not present.

I believe I am updated to the latest kernel, I am using 4.4.0-81-generic and just checked in synaptic to make sure all networking and headers are updated and there are no broken dependencies. You are also correct that it is a very new device and the drivers did not work for this model computer 4 months ago as I tested then. But as of now they do work as it works when i boot Ubuntu from USB. Linux was downloaded over 4 months on the original computer so what you are saying sounds completely correct that i need to upgrade but just not sure how to upgrade or what to upgrade.

When running the command that you asked I believe the line you are inquirying about says:

04:00.0 Network controller [0280]: Intel Corporation Device [8086:24fd] (rev 78)

If not this one then the only other thing thats pulled up dealing with the network is the ethernet controller.


  • 1
    Take a look at /etc/udev/rules.d/70-persistent-net.rules. If exists and contains your device, delete row and reboot. These entries are created (at boot time) for new network-devices and refers to the mac address. – ChristophS Jun 26 '17 at 8:13
  • Please identify the wifi card either with lspci -nn or lsusb, the single line with the device is enough. You may need a newer kernel or even custom drivers if the wifi card is very new. – dirkt Jun 27 '17 at 7:47

I had a similar problem after cloning my Kubuntu 16.04 with Acronis True Image 2018.  Specifically, I was getting DNS_PROBE_FINISHED_BAD_CONFIG in the browser when trying to navigate to any site.

What worked for me was Gayan Weerakutti’s answer at Ask Ubuntu:

sudo dpkg-reconfigure resolvconf

Say yes to "prepare /etc/resolve.conf for dynamic updates?"

sudo reboot

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.