0

I'm using an NXP embedded linux board and I compiled u-boot, the kernel and am using a linaro rootfs.

On it I installed freeswitch and loaded mod_gsmopen with a Huawei module and it didn't work. After a little bit of reading the conf file I found that it was trying to read ttyUSB3, so I tried finding the correct ttyUSB but I can't find any /dev/ttyUSB modules, even though it detects the module.

I've tried using lsusb, lsblk and lsmod but only lsusb gives me something about the USB module.

After some reading and trying to find a similar problem, I saw some posts telling me to try

modprobe usbserial depmod

Modprobe command gives me the result:

modprobe: ERROR: ../libkmod/libkmod.c:557 kmod_search_moddep() could not open moddep file '/lib/modules/4.1.15/modules.dep.bin'

And depmod gives me:

depmod: ERROR: could not open directory /lib/modules/4.1.15: No such file or directory depmod: FATAL: could not search modules: No such file or directory

I found on a post to do something likes this:

apt-get install --reinstall linux-image-`uname -r\`

But it doesn't find the package. When I do an apt-cache search linux-image I get many results, ranging from linux-image-4.4 to 4.9, which leads me to believe that there isn't any linux-image available for my version of the kernel and I don't know if I can install something from a newer version of the kernel.

My solution so far has been downloading kernel 4.9.34 which is longterm and recompile it from scratch again, but there is a chance that the problem persists and also this tkes a long time in my machine. Does anyone have any easier solutions?

PS: I'm on armhf, i.MX6ULL module from NXP. Also, /lib/modules does not exist on my machine

0

Ok. So I had many problems, so let's start from the beginning.

At that time I was trying to compile the drivers builtin into the kernel and not as a module. For some reason that didn't work so I decided to compile them as modules separately and installing them later.

The main problema I wasn't finding any package when doing apt-get was because I wasn't using a kernel version that had the linux image ready for installation. Basically I needed to install compile and install it myself.

One other thing that made everything start working was when I started compiling the linux headers, without doing that I'd probably still be trying to get my board to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.