2

I just installed Debian 9 (Stretch) this morning and I can't get my Meta key working. It used to work completely fine in Debian 8 (Jessie) and I don't remember having any problem.

The X server seems not to see the key at all. xev sees nothing at all when pressing the Meta key. All other keys on my keyboard work fine. The keyboard is a Logitech G710+ ; setxkbmap -print -verbose 10 says rules are evdev, and model is pc105, which is fine as far as I can tell.

I made sure the desktop environment I'm running (KDE5) does not interfere in the following way : I've downed the entire X environment, logged in on the text console, ran X :0 and a term in :0, from where I've run xev without even a window manager running, but the result is the same : the Meta key alone is not seen by xev.

So far I've always used xev to figure out where keys are getting blocked, but this time it does not even see anything happening and my internet searches have not turned up anything I could use to figure out what's wrong.

What would be the next step for me to investigate what's happening ?

  • First step is to run evtest as root on the keyboard input device, and see which keysym the Meta key generates. This should show if the problem is in X, or on the level(s) below. Is it a PS/2 or USB keyboard? – dirkt Jun 24 '17 at 12:06
  • Thanks. It's a USB keyboard. As per your recommendation, I ran evtest on my keyboard. The Meta key is not seen at all, all other keys are like with xev. So that points to a problem in evdev ? I'll be trying to search in this direction ; any further help welcome as I still have no idea where things are wrong. – Jean Jun 24 '17 at 12:29
  • Oh, and another thing : on the console, showkey also can't see the Meta key but sees all other. – Jean Jun 24 '17 at 12:30
4

That means either the key is physically or electrically broken in some way (and the upgrade to Debian is unrelated), or the HID to input layer translation doesn't work for some reason.

Look into dmesg for the associated /dev/hidrawX device (unplug and re-plug to force detection if you can't find it). Run hexdump -C /dev/hidrawX on this device, and press and release some key (e.g. space) a few times. You should see a repeating pattern of about 14 bytes. Careful, output is buffered, you will only see complete lines. Then try the same with the Meta key a few times. Then with the space key again, to make sure you are not missing buffered lines.

If you don't get anything for the Meta key, it's broken. If you do get something, please edit question with this output. Also, as root, mount -t debugfs none /sys/kernel/debug. Do cat /sys/kernel/debug/hid/DEVICE_ID/rdesc for the DEVICE_ID that corresponds to your keyboard (see dmesg), and update question with output.

  • 1
    Meh. I am sorry to have wasted your time. I tried the keyboard on another computer and the key indeed did not answer. This is when I realized there is a key on the keyboard to (electrically) disable the Meta key intended for gamers for whom pressing this key under windows gets you out of a fullscreen game. I had pressed that disabling key inadvertently. Sure enough, pressing it again made the Meta key work as expected everywhere. Sorry again to have wasted your time (and a good 4 hours for me today). At least I learned new things today about input. Thanks for having educated me. – Jean Jun 24 '17 at 14:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.