I'm using xfreerdp to connect to Windows Server 2008 R2 Standard as a regular user. I need to use participate in a telecon using Skype for Business. Therefore, I need to forward both audio and microphone. I can do without webcam (although it would be a nice bonus). Following advice here, I have installed a recent nightly build of xfreerdp. I connect with the commandline shown below. On the remote desktop, playback sound works, but if I go Start → Control Panel → Hardware → Sound → Recording, there is a message “No audio devices are installed”, and indeed Skype for Business agrees that I have no microphone.

I have tried to pass microphone information either as /microphone or as /microphone:sys:alsa, as shown below. I am connecting from Ubuntu 14.04 (Trusty) via a VPN through Pulse 5.2R6.

What do I need to do to make the microphone work?

$ /opt/freerdp-nightly/bin/xfreerdp /w:800 /h:640 /u:yw910419 /d:RDG-HOME /sound /microphone:sys:alsa +fonts /v:hysteria.rdg.ac.uk
[16:15:21:510] [17809:17810] [INFO][com.freerdp.client.common.cmdline] - loading channelEx rdpdr
[16:15:21:510] [17809:17810] [INFO][com.freerdp.client.common.cmdline] - loading channelEx rdpsnd
[16:15:21:510] [17809:17810] [INFO][com.freerdp.client.common.cmdline] - loading channelEx drdynvc
[16:15:24:073] [17809:17810] [INFO][com.freerdp.gdi] - Local framebuffer format  PIXEL_FORMAT_BGRX32
[16:15:24:073] [17809:17810] [INFO][com.freerdp.gdi] - Remote framebuffer format PIXEL_FORMAT_RGB16
[16:15:24:092] [17809:17810] [INFO][com.winpr.clipboard] - initialized POSIX local file subsystem
[16:15:24:103] [17809:17810] [INFO][com.freerdp.channels.drdynvc.client] - Loading Dynamic Virtual Channel audin
[16:15:24:103] [17809:17810] [INFO][com.freerdp.channels.audin.client] - Loaded alsa backend for audin
[16:15:24:106] [17809:17816] [INFO][com.freerdp.channels.rdpsnd.client] - Loaded pulse backend for rdpsnd
[16:15:25:816] [17809:17810] [INFO][com.freerdp.client.x11] - Logon Error Info SESSION_ID [LOGON_MSG_SESSION_CONTINUE]

The solution is:

  • Open command prompt (cmd.exe) as administrator.
  • Type "gpedit" (without the quotes) and press Enter.
  • Go to Computer Configuration --> Administrative Templates --> Windows Components --> Remote Desktop Services --> Remote Desktop Session Host --> Device and Resource Redirection.
  • Double click on "Allow audio and video playback redirection".
  • Select "Enabled", type "Yes" (without the quotes) in the Comment text box. Click Apply
  • Click "Next Setting".
  • Make sure it's "Allow audio recording redirection" and do the same. Click OK.
  • Log off (not only your remote desktop session, but your current actual session) and log on again, making sure "Bring audio to this computer" is select in your remote desktop options

On Xubuntu the part of command line to run client (FreeRDP version 2.0.0-dev): xfreerdp /sound:sys:alsa /microphone:sys:alsa

related Microsoft forum link

  • Opening line on my question says "as a regular user". I don't have administrator access on the remote desktop.
    – gerrit
    Sep 29 '17 at 13:46
  • /microphone:sys:alsa not worked for me. but the option /microphone is worked. thanks.
    – Akhil
    Sep 26 '20 at 11:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.