2

I have a server with a mounted veracrypt volume (inner is NTFS, but tried ext4 with same results) and want to share it inside my local network with other computers (mostly windows).

The problem is, I cannot change the permissions for this volume (permissions are 700) thus samba gives an error because permissions are not correct. I share the folder via the same samba user who's mounted the veracrypt device, but still no permissions to view the folder. Other folders like home and everything inside home of the user are working fine.

If I do the same using windows, there is no problem and all computers can access the drive via network.

Does anybody know a workaround or is there a mistake (e.g. like, should every computer mount this drive)? I just want to secure the drives against physical access.

Thanks in advance, SJF

  • What is the point of having an encrypted disk and share this on your network? If you answer my question first, i can think on an answer to you(not sure if i will find it)... – user34720 Jun 23 '17 at 11:56
  • The point is: I can access the files from my server from my computers but if I don't need the data, so the drive is unmounted, it is secured. – SirJohnFranklin Jun 24 '17 at 10:40
0

In Veracrypt, before mounting the volume, go to preferences > mount options, and add "umask=022" as mount option string, this adds read and execute permissions to group and others, you can also change it to 000 for full access. Mount your volume. The samba share should work then.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.