0

I couldn't find packages such as "git" with Synaptic's search anymore (it used to work earlier) so I tried to reinstall it as described here: https://askubuntu.com/questions/496827/well-known-packages-are-not-shown-in-synaptic-package-manager and now I don't have Synaptic anymore.

In particular I tried these commands:

sudo apt-get --purge autoremove synaptic

to uninstall. That worked the first time; when I run it again it shows:

Reading package lists... Done
Building dependency tree
Reading state information...
Done
Package 'synaptic' is not installed, so not removed 0 upgraded, 0 newly installed, 0 to remove and 9 not upgraded.

sudo apt-get install synaptic

to install it again, where I get:

Reading package lists...
Done
Building dependency tree
Reading state information...
Done
Package synaptic is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source
E: Package 'synaptic' has no installation candidate

I'm using a freshly installed Debian 9.0.0 with Cinnamon and my sources.list file has these sources set:

deb http://security.debian.org/debian-security stretch/updates main
deb-src http://security.debian.org/debian-security stretch/updates main

deb http://deb.debian.org/debian/ stretch-updates main
deb-src http://deb.debian.org/debian/ stretch-updates main

Edit: when I try to install it by downloading synaptic_0.84.2_amd64.deb in https://cdn-aws.deb.debian.org/debian/pool/main/s/synaptic/ from my browser I get:

Error: Dependency is not satisfiable: libept1.5.0" in the Package Installer.

If there's a problem with dependencies missing (e.g. because I uninstalled something) why doesn't it install them along with synaptic and how to fix this?

  • 1
    Package 'synaptic' is not installed, so not removed 0 upgraded, 0 newly installed, 0 to remove and 9 not upgraded. Please try again after the 9 are upgraded. Use sudo -i followed by apt-get update && apt-get upgrade – eyoung100 Jun 22 '17 at 21:42
  • I only did apt-get update prior to this - but upgrading didn't didn't help either. Now it says 0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded. and I still get the same messages when trying to install synaptic. I guess I need to upgrade these 2 packages as well to get it working? I don't know which of the packages those are and why they're having problems though. – mYnDstrEAm Jun 22 '17 at 21:51
  • It says: The following packages have been kept back: firefox-esr firefox-esr-l10n-d. I just restarted my PC and did not start up firefox and it still didn't work. – mYnDstrEAm Jun 22 '17 at 21:57
  • See libept-1.5.0, and synaptic-0.84.2. It looks like --purge removed libept which was a dependency for synaptic. Then purge firefox, and download the newest version for Debian – eyoung100 Jun 22 '17 at 22:09
  • So sudo apt-get --purge autoremove firefox-esr and sudo apt-get install firefox-esr right? Would that delete my session and all my settings etc? Or would they be kept? Should I do the same for libept afterwards? – mYnDstrEAm Jun 22 '17 at 22:21
1

OK, you are bringing up multiple questions in your comments/replies to other answers...

For the original question - your default /etc/apt/sources.list should look something like

deb http://ftp.us.debian.org/debian/ stretch main 
deb http://security.debian.org/debian-security stretch/updates main

You currently have stretch-updates channels enabled, but no primary stretch channel.

With just those 2 lines in my /etc/apt/sources.list and nothing in /etc/apt/sources.list.d I can install synaptic on a fresh netinstall of "base system utilities" only Debian 9 downloaded about 3 hours ago.

Put your sources.list file back to that, do an apt-get update and see if you can reinstall synaptic.

This will also likely fix the firefox-esr that is being held back, etc.

  • Probably a apt-get upgrade or even better an apt-get dist-upgrade after the update will actually install what may be needed. The update alone will not change the system. – Arrow Jun 23 '17 at 1:26
  • Alright apt-get upgrade did not help but apt-get dist-upgrade did upgrade my firefox apparently as it now says 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.. Now I could install synaptic. And I could install git with it :D Thank you all for your help! – mYnDstrEAm Jun 23 '17 at 15:49
0

Problem

You removed a package by force from the command line. Using the --purge option removed the file and it's dependencies were caught by autoremove. This combination together purges the named package and all it's dependencies, plus all the configuration data.

Resolution

We need to determine the list of packages that the package we removed depends on, like so (this list is from a XUbuntu install, but the result will be nearly identical, as Ubuntu is a Debian fork):

sudo -i
apt-cache depends synaptic
synaptic
  Depends: libapt-inst2.0
  Depends: libapt-pkg5.0
  Depends: libc6
  Depends: libept1.5.0
  Depends: libgcc1
  Depends: libgdk-pixbuf2.0-0
  Depends: libglib2.0-0
  Depends: libgtk-3-0
  Depends: libpango-1.0-0
  Depends: libstdc++6
  Depends: libvte-2.91-0
  Depends: libx11-6
  Depends: libxapian30
  Depends: hicolor-icon-theme
  Depends: policykit-1
    policykit-1:i386
  Conflicts: menu
  Recommends: libgtk2-perl
  Recommends: rarian-compat
  Recommends: xdg-utils
  Suggests: dwww
  Suggests: menu
    menu:i386
  Suggests: deborphan
  Suggests: apt-xapian-index
  Suggests: tasksel
  Suggests: software-properties-gtk

In your case, from your Edit(I've edited your question to highlight the error), we determined that the missing package is: libept1.5.0, listed as libept1.5.0 (1.1+nmu3 and others) in the Debian Stretch Package Repository.

We must now download the missing package from the repository, by visiting Package: libept1.5.0 (1.1+nmu3 and others): High-level library for managing Debian package information. Scroll down to the bottom of the window, and download the package appropriate for your architecture. Ignore the note on the resulting page, as we tried that first.

After saving the package, start a new terminal window, and cd /path/to/downloaded/file. Issue sudo dpkg -i libept1.5.0_1.1+nmu3+b1_<arch>.deb to install the package.


Extra Credit

Use CAUTION if attempting this: I'm offering this because the package we downloaded should be in your repository. Since I have no idea what state your repositories and list are in, I'm starting from scratch.

Taken from How do I restore the default repositories? over at AskUbuntu, but the concept is the same. There is a sources.list generator for Debian at Debian Sources List Generator.

  1. Install the packages required by the Generator: apt-get install curl wget apt-transport-https dirmngr
  2. Remove your sources list, by issuing: sudo rm /etc/apt/sources.list
  3. Configure the options etc, most importantly, choose the Proper Version. Once the version is chosen, choose any third party mirrors if desired.
  4. Click Generate.
  5. Use some form of sudo, i.e. gksudoto open your chosen text editor. You need to be root to save the result in the /etc/ directory.
  6. Copy the results of step 4 into the editor in step 5. If you chose any third party repositories, don't forget to issue the commands in the GPG Keys output window.
  7. Save the result as sources.list in /etc/apt/
  8. Issue a sudo apt-get update

Example Output from Generator

#------------------------------------------------------------------------------#
#                   OFFICIAL DEBIAN REPOS                    
#------------------------------------------------------------------------------#

###### Debian Main Repos
deb http://deb.debian.org/debian/ stable main contrib non-free
deb-src http://deb.debian.org/debian/ stable main contrib non-free

deb http://deb.debian.org/debian/ stable-updates main contrib non-free
deb-src http://deb.debian.org/debian/ stable-updates main contrib non-free

deb http://deb.debian.org/debian-security stable/updates main
deb-src http://deb.debian.org/debian-security stable/updates main

deb http://ftp.debian.org/debian jessie-backports main
deb-src http://ftp.debian.org/debian jessie-backports main
  • Probably easier to supply the 2 lines needed for the sources.list and go from there... – ivanivan Jun 23 '17 at 0:10
  • @eyoung100 Instead of downloading the package I'm trying to get the sources.list working. For this I tried the Debian Sources List Generator; however when I execute apt install curl wget apt-transport-https dirmngr I get: Package curl is not available, but is referred to by another package. [...] E: Package 'curl' has no installation candidate E: Unable to locate package apt-transport-https I'll probably try to manually replace the sources.list with the ones generated there now? – mYnDstrEAm Jun 23 '17 at 10:59
  • @mYnDstrEAm Please, oh please, stop jumping around and trying everything from everywhere. You are just making a problem a lot worse than it needs to be by trying exotic things. Do not, I will repeat, do not change sources.list to anything other than the two lines that ivanivan posted in this answer, That is the correct value, yes, just two lines, that's all. Once that is there, we can move to other issues. – Arrow Jun 23 '17 at 11:27
  • @Arrow Commented out everything in that file and put those 2 lines in. Then I ran apt-get update and tried to install synoptic afterwards - I still get E: Unable to locate package synoptic. – mYnDstrEAm Jun 23 '17 at 15:41
  • @mYnDstrEAm Have you run apt-get upGRADE ??? And, It is synaptic, not synoptic. If you just run upDATE, no real change is done to the system. Please run upGRADE. – Arrow Jun 23 '17 at 17:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.