0

While trying to install i3 (window manager) on my Debian machine I had some wired dependency error.

The following packages have unmet dependencies:
gsettings-desktop-schemas : Breaks: gnome-settings-daemon (< 3.19.92) but 3.14.2-3+deb8u1 is to be installed
                            Breaks: mutter (< 3.19.92) but 3.14.4-1~deb8u1 is to be installed
N: Ignoring file '50unattended-upgrades.ucf-old' in directory '/etc/apt/apt.conf.d/' as it has an invalid filename extension
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Last Saturday -- while running apt-get upgrade -- Debian upgraded from 8 "Jessie" to 9 "Stretch". Could the problem be connected to that upgrade?

Researching for aid I couldn't find something which fits to my situation. While I enjoy Debian much, I'm not a power user. I would be very thankful for any support.

apt-cache policy gnome-settings-daemon mutter shows

gnome-settings-daemon:
  Installed: 3.14.2-3+deb8u1
  Candidate: 3.22.2-2
  Version table:
     3.22.2-2 0
        500 http://ftp.de.debian.org/debian/ stable/main amd64 Packages
 *** 3.14.2-3+deb8u1 0
        500 http://ftp.de.debian.org/debian/ oldstable/main amd64 Packages
        500 http://httpredir.debian.org/debian/ jessie/main amd64 Packages
        100 /var/lib/dpkg/status
mutter:
  Installed: 3.14.4-1~deb8u1
  Candidate: 3.22.3-2
  Version table:
     3.22.3-2 0
        500 http://ftp.de.debian.org/debian/ stable/main amd64 Packages
 *** 3.14.4-1~deb8u1 0
        500 http://ftp.de.debian.org/debian/ oldstable/main amd64 Packages
        500 http://httpredir.debian.org/debian/ jessie/main amd64 Packages
        100 /var/lib/dpkg/status
N: Ignoring file '50unattended-upgrades.ucf-old' in directory '/etc/apt/apt.conf.d/' as it has an invalid filename extension
  • Could you edit your question to add the output of apt-cache policy gnome-settings-daemon mutter? – Stephen Kitt Jun 22 '17 at 15:28
  • @StephenKitt : Thank you :) Here you find the requested output pastebin.com/Sjcr4Lxu – alex Jun 22 '17 at 15:33
2

You’ve got a mixture of sources causing conflicts, in particular codename-based repositories (“jessie”) along with generic repositories (“stable”).

Now that you’ve (partially) upgraded to Debian 9, you need to edit your sources so that

  • all lines referring to “oldstable” are commented out
  • all lines referring to “stable” refer to “stretch” instead
  • all lines referring to “jessie” refer to “stretch“ instead

By specifying the release codename, you’ll avoid the sudden upgrade when the next release comes out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.