I'm using KDE neon distribution (Ubuntu 16.04 LTS + latest KDE5 DE).

Suspend+resume looks to be mostly working on my notebook, but the labels under icons (I have "folder view" set up as background in plasma shell) are corrupted, like this:

screenshot of corrupted labels on desktop

On the left side corrupted icon, on the right fixed by dragging the icon few pixels and letting it drop back to its original place.

Looks to me, as it may be not graphics driver issue, but even KDE5 plasma folder view caching bug?


  • how to refresh the whole desktop easily? The KDE menu "Refresh Desktop" does not help (I guess there's some cache for icons, and it is not invalidated).

  • how to create some high quality bug report, what kind of logs/commands output is worth of it, and where even to start to hunt down this one.

While I'm programmer myself, I don't do any Qt/KDE5 development, so I don't have even idea, which part of KDE is responsible for these, where to look for errors and which tools are available for diagnostics. A quick look into dmesg and /var/log/Xorg.0.log didn't bring up anything suspicious.

lshw -c video

       description: 3D controller
       product: GM107M [GeForce GTX 960M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:130 memory:de000000-deffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:e000(size=128) memory:df000000-df07ffff
       description: VGA compatible controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 06
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915_bpo latency=0
       resources: irq:125 memory:dd000000-ddffffff memory:b0000000-bfffffff ioport:f000(size=64)

glxinfo | grep OpenGL

OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 960M/PCIe/SSE2
OpenGL core profile version string: 4.5.0 NVIDIA 375.66
OpenGL core profile shading language version string: 4.50 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.5.0 NVIDIA 375.66
OpenGL shading language version string: 4.50 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 375.66
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:
  • Seems to be fixed for me now (latest KDE neon packages, 4.16.7 mainline kernel), but I can't recall since when, and if it's reliably fixed always, it just occurred to me now, that I didn't click the "restart plasma" script on desktop for some time. (seems like glxinfo is now picking Intel integrated GPU, not nVidia, may be part of the "solution", but I would need more time and knowledge to tell what exactly is going on, if I don't use nVidia GPU any more, or what)
    – Ped7g
    May 18, 2018 at 14:54
  • As I suspected, I don't have working nVidia GPU config any more, all my gfx is now done by Intel only (trying to switch on the nVidia-prime / optimus thing to use the 960M for performance made my kernel completely freeze during startup, so I gave up for this moment, as I'm running mainline kernels from testing due to WiFi problems, and the slower GPU doesn't affect me as badly as non broken network. = I don't know if current nVidia driver is fixed already or KDE has workaround, I would guess NOT, so the issue is probably still alive.
    – Ped7g
    Jun 13, 2018 at 6:44

5 Answers 5


I know your pain, this has been annoying me for months now.

  1. The only way to fix the desktop I've found is brute force, I made a shortcut to do this and run it every time I resume from standby:

    killall plasmashell; kstart plasmashell

EDIT: 2020/10/6 - this bug has since been fixed, but for reference: restart command for plasma 5.18.5 is now:

kstart5 plasmashell -- --replace
  1. I can't properly answer this but I'm posting all the info I've got so I can link this from the bug report page. The glitching is a long standing issue with the NVidia drivers and KDE plasma, previously the same question was asked here but it got falsely marked as a duplicate of a similar related issue: https://askubuntu.com/questions/897928/kde-desktop-icons-glitched-after-suspend-kubuntu-16-10

I had some hope after the recent 5.10.3 plasma update as it was supposed to be fixed https://bugs.kde.org/show_bug.cgi?id=344326 https://www.phoronix.com/scan.php?page=news_item&px=KDE-Plasma-5.10.3-Released , but it didn't fix the issue for me.
I'm going to follow up on that bug report with a link to this post so also attaching an image of the bug on my system here.

(EDIT: found the actual bug report for Plasma https://bugs.kde.org/show_bug.cgi?id=382115)

(EDIT2: found the bug report for QT: https://bugreports.qt.io/browse/QTBUG-56610 and NVidia forum thread https://devtalk.nvidia.com/default/topic/971972/linux/icon-text-label-corruption-with-kde-plasma-5-desktop-folder-view/)

$ cat /etc/issue
Ubuntu 17.04 \n \l
$ uname -a
Linux desktop 4.10.0-26-generic #30-Ubuntu SMP Tue Jun 27 09:30:12 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
$ plasmashell --version
plasmashell 5.10.3

Desktop icons after suspend/resume

  • 1
    I'm on KDE neon, so I have now plasma 5.10.3 and all the other things updated, still the plasma has those issues (as pointed in the bug comments, it should). Your workaround to restart plasmashell WFM for the moment. I wonder whether the "Refresh desktop" in the context menu can't invalidate also all contexts/etc, i.e. to be much more aggressive about not just refreshing, but restarting parts of plasma. Because generally I can't recall to need a desktop refresh, usually everything works nicely and all the file changes/etc. are picked up automatically, so having heavy refresh would be OK for me
    – Ped7g
    Jul 14, 2017 at 2:01
  • @Ped7g Yes it would be nice if that refresh entry actually did something in cases of real gfx corruption, could be worth following that up as a feature suggestion. After following the bouncing bug reports again the issue currently rests at this old QT bug here: bugreports.qt.io/browse/QTBUG-56610 - I'm sure I found this ages ago last time I looked this up but gave up as the conclusion seems to be NVidia need to fix their drivers. According to Nvidia devtalk thread that is on the cards but who knows when it will happen.
    – Ozone
    Jul 19, 2017 at 11:58
  • 3
    Thanks! On Manjaro and possibly archlinux kstart is kstart5 so killall plasmashell; kstart5 plasmashell
    – squareborg
    Jun 3, 2018 at 7:22
  • 1
    Personally, considering those long-lasting errors (basically they don't care about Linux), and also their war against OpenCL keeping intentionally version to 1.2 outdated 14years ago... I will never again buy an NVidia card. Oct 6, 2020 at 6:53
  • 1
    Plasma 5.18.5 didn't fix the issue for me (Kubuntu 20.04, KDE 5.68.0, Qt 5.12.8, Kernel 5.4.0-65, Nvidia drivers 450.102.04) Jan 29, 2021 at 7:50

I have had the same problem with Kubuntu 18.04. Having gone read several posts about this problem, I've combined the answers into a solution that works automatically. There is a small Bash script that runs in the background and kills/restarts plasmashell every the user returns from lock screen. You can find the answer to the link below (script and way to run it automatically)

Kubuntu 18.04, cron task does not load @reboot

I hope you find it useful!


I found the following fix for this:

  • Go To NVIDIA X Server Settings -> Prime Profiles -> Check NVIDIA On-Demand

  • Logout and login into the system

The problem will go and your transitions will become smooth as well. It worked for me and my friend on Kubuntu 19.10 Plasma version 5.17.5

Image for Reference

  • 1
    That's technically not a fix, you just switch the usage of nVidia vs Intel GPU from "always nVidia" to dynamic switching depending on GPU load. But it may actually help, as most likely when you are putting the machine to sleep, it's probably under low GPU load, and so it's the Intel GPU used to sleep+wake, which works well. Then maybe when it does switch to nVidia later, it will refresh the internal buffers correctly. Can't try/confirm, because I don't have working nvidia driver for my current kernel. The plasma restart in other answer will work in any case, not depending on actual GPU used
    – Ped7g
    Jan 21, 2020 at 16:20
  • This fixed the problem for me. Jun 8, 2020 at 6:29

I've just encountered the same issue on my current & stable Fedora.

# uname -a
Linux ### 4.16.14-300.fc28.x86_64 #1 SMP Tue Jun 5 16:23:44 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

# lsb_release -a
LSB Version:    :core-4.1-amd64:core-4.1-noarch:cxx-4.1-amd64:cxx-4.1-noarch:desktop-4.1-amd64:desktop-4.1-noarch:languages-4.1-amd64:languages-4.1-noarch:printing-4.1-amd64:printing-4.1-noarch
Distributor ID: Generic
Description:    Generic release 28 (Generic)
Release:        28
Codename:       Generic

# lspci -k | grep -A 2 VGA
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
        Subsystem: Hewlett-Packard Company Device 1942
        Kernel driver in use: i915
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Mars [Radeon HD 8670A/8670M/8750M]
        Subsystem: Hewlett-Packard Company Device 1947
        Kernel driver in use: radeon

# lshw -c video
       description: VGA compatible controller
       product: Mars [Radeon HD 8670A/8670M/8750M]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: vga_controller bus_master cap_list rom
       configuration: driver=radeon latency=0
       resources: irq:34 memory:90000000-9fffffff memory:b0900000-b093ffff ioport:4000(size=256) memory:b0940000-b095ffff
       description: VGA compatible controller
       product: 4th Gen Core Processor Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 06
       width: 64 bits
       clock: 33MHz
       capabilities: vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:33 memory:b0000000-b03fffff memory:a0000000-afffffff ioport:5000(size=64) memory:c0000-dffff

Screencaps @

Yet to test after a suspect/hibernate, but feels consistent with experience. Will upate

  • 2
    You have AMD/ATI card, and you experience it before resume from hybernation, i.e. your problem is completely unrelated, even if the artefacts are graphically very similar, try to search more to find something related to your situation. The problem described in original question is known nVidia driver feature/bug, and can't affect your HW.
    – Ped7g
    Jun 13, 2018 at 6:40

I fixed the problem here by adding:


to ~/.config/plasmashellrc

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .