5

I have Lubuntu 17.04 with i3 window manager. I am tryig to open the network manager from the i3wm but I can't. The internet connection works by going to the defaiult network that I set via LXDE, however unless I log back in via LXDE, I can't change the network via nm-applet. When I run nm-applet in the terminal in i3, nothing happens. Any suggestions? (I just want to be able to change between the wifi networks using the mouse, I don't want to work in the command line for that.)

Addendum:

Here is the output of systemctl status dbus-org.freedesktop.nm-dispatcher.service

● NetworkManager-dispatcher.service - Network Manager Script Dispatcher Service
   Loaded: loaded (/lib/systemd/system/NetworkManager-dispatcher.service; enabled; vendor preset: enabled)
   Active: active (running) since Sun 2017-06-25 21:35:57 EDT; 967ms ago
 Main PID: 1477 (nm-dispatcher)
    Tasks: 3 (limit: 4915)
   CGroup: /system.slice/NetworkManager-dispatcher.service
           └─1477 /usr/lib/NetworkManager/nm-dispatcher

Jun 25 21:35:57 dot-HP-Compaq-8200-Elite-USDT-PC systemd[1]: Starting Network Manager Script Dispatcher Service...
Jun 25 21:35:57 dot-HP-Compaq-8200-Elite-USDT-PC systemd[1]: Started Network Manager Script Dispatcher Service.
Jun 25 21:35:57 dot-HP-Compaq-8200-Elite-USDT-PC nm-dispatcher[1477]: req:1 'dhcp6-change' [wlxc83a35c67f33]: new request (1 scripts)
Jun 25 21:35:57 dot-HP-Compaq-8200-Elite-USDT-PC nm-dispatcher[1477]: req:1 'dhcp6-change' [wlxc83a35c67f33]: start running ordered scripts.
lines 1-12/12 (END)

Update 2:

I was able to pinpoint to the problem and it is a strange one (does not change with exec_always): When I use an additional screen, then the nm-applet does not show up while everything else is there. If I disconnect the second monitor and reboot the PC, it shows up in the rigth lower corner as it's supposed to.

7
  • Have you tried adding exec --no-startup-id nm-applet to your i3 config? What does systemctl status dbus-org.freedesktop.nm-dispatcher.service return during an i3 session? Jun 25, 2017 at 20:57
  • @RichardBorder actually after I rebooted it it is no longer working. The output to your command is incorporated in the updated post above.
    – Oposum
    Jun 26, 2017 at 1:35
  • howabout adding exec_always --no-startup-id nm-applet instead? also, try systemctl enable network-manager.service Jun 26, 2017 at 19:34
  • @RichardBorder I was able to pinpoint to the problem and it is a strange one (does not change with exec_always): When I use an additional screen, then the nm-applet does not show up while everything else is there. If I disconnect the second monitor and reboot the PC, it shows up in the rigth lower corner as it's supposed to.
    – Oposum
    Jun 27, 2017 at 0:02
  • Do any other tray icons show up with both monitors? You might just need to set a primary monitor via xrandr or arandr or set your tray_output to the specific display you want in your i3 conf Jun 27, 2017 at 0:31

2 Answers 2

6

Per the Arch Wiki try:

exec --no-startup-id nm-applet --sm-disable

in your .i3config. That's supposed to fix issues with non-XDG WMs. I'm running i3 (single monitor though, so results might be skewed) and run it that way.

2
  • 2
    thanks for the suggestion, tried it but doesn't work.
    – Oposum
    Jun 30, 2017 at 0:36
  • Worked perfectly on lubuntu Jan 29, 2020 at 19:49
4

After trying numerous suggestions found here and elsewhere, my solution was:

bar {
         tray_output primary
         status_command i3status
}

be careful with the c&p, not sure it'll format correctly

2
  • you added this at the end of the config file?
    – Oposum
    Sep 20, 2017 at 19:09
  • I've found that I have to toggle output or tray_output on and off (commenting and restarting i3) depending on the machine I'm on and the video card drivers and monitor layout present. Plugging in an external monitor tends to break the tray because "primary" might change, I need to dig in sometime but with a 4K laptop I haven't had much incentive yet.
    – dragon788
    Sep 30, 2017 at 23:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.