2

After patching Ubuntu and Firefox ESR today (2017/6/21) the Java Plugin suddenly started to crash.

enter image description here

###!!! [Parent][MessageChannel::Call] Error: Channel error: cannot send/recv

I have tried to empty the browser and Java Plugin caches.

I have also tried to enable the plugin console and logging but nothing indicating a crash is logged to ~/.java/deployment/log

2
  • This seems to be the second question about this subject this week: Java plugin crashes after Firefox upgrade(this one is the other - unix.stackexchange.com/questions/372260/…). I suspect you guys will have to open a bug on Mozilla's bugzilla.
    – user34720
    Jun 21, 2017 at 20:07
  • I have registered a support question on the Mozilla Support Forum.
    – dagb
    Jun 22, 2017 at 4:48

1 Answer 1

1

I have this problem too and I found a workaround. The bug is related to newest Linux kernel (I have this bug on 4.8.0-56-generic kernel on Ubuntu MATE). After booting the system using 4.8.0-54-generic kernel, Java plugin stopped crashing. Glad I didn't used apt-get autoremove this time to remove older kernel :).

4
  • That solved the problem. Thanks! It is a confirmed bug, or something that is changed? Given the limited use of Java plugin these days I guess testing changes against it is limited.
    – dagb
    Jun 22, 2017 at 6:56
  • As Java is turning into a dead tecnology for browsers(plugin/client site) so, i also doubt someone will pay attention on solving ths issue.
    – user34720
    Jun 22, 2017 at 10:44
  • Yes, I am afraid so. The sole reason for my concern with this as is a VPN vendor slow moving away from applets.
    – dagb
    Jun 23, 2017 at 4:47
  • It seems like Eclipse and some other applications are effected so maybe a fix will be on it's way Eclipse Crashes with Linux Kernel 4.4.0-81-generic
    – dagb
    Jun 23, 2017 at 5:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .