0

On my Linux clients (most Ubuntu) I changed the umask to 0002. After that every newly created file or folder have write permissions for the group.

Unfortunately this is only working for creation, not for copies. If I copy existing folders, the group permissions are also copied. If source folders and files have only read permissions for group, the files and directories also get only read permissions for groups.

Any idea how to fix this? I'd welcome server side configurations if possible.

0

You could use rsync chmod option to add read permissions to your destination files:

rsync -r --chmod=g+rX source/ dest/

Notice the / at the end of both source and dest. They indicate that you should copy the contents of source into dest directory. If you'd like to have a «source» directory inside dest, then omit the / from source.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.