2

After upgrading from Debian 8 to Debian 9, the text editor Pluma (a Gedit fork) no longer use my custom DPI setting. I noticed the same thing with the editor Geany. Here are my Xft settings in ~/.Xresources:

Xft.antialias: true
Xft.autohint: false
Xft.dpi: 100
Xft.hinting: true
Xft.hintstyle: hintslight
Xft.lcdfilter: lcddefault
Xft.rgba: rgb

The other Xft settings above are picked up Pluma, however. On the other hand, the text editor Leafpad correctly uses the DPI setting. Any clues? I use the window manager Blackbox started from a console.

Pluma (with DejaVu Sans 10):

enter image description here

Leafpad (with DejaVu Sans 10):

enter image description here

0

GTK3 use theming, so you need to configure the style sheets used by it (not ~/.Xresources). Read also about GTK application resources.

The gnome-tweak-tool application and package provides a GUI interface to changing themes, etc.

You might consider setting the scale property of fonts. It is not exactly the DPI, but is related (see also this).

(perhaps the GTK theming machinery knows about DPI, but I can't tell how)

BTW, if using Xorg X11 server, you could consider configuring the DPI resolution of your screen (see e.g. this); read also about xrandr. this works on the server side so should has an effect on every X11 client (even non-GTK based). If using Wayland, you might find something relevant too.

  • What configuration file should I use? What property should I set? – August Karlstrom Jul 3 '17 at 11:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.