2

In gnome-terminal, lxterminal and mlterm under Lubuntu 16.04, when pressing PgUp nothing happens, and the symbol ~ appears when PgDn is pressed, but the information won't scroll up or down. This is not the case for navigators and text editors, where they behave as expected. How can this be changed for a terminal?

3
  • 4
    Try shift+PageUp – DevilaN Jun 21 '17 at 10:23
  • @DevilaN That solved the problem. Not that I can't get used to it, but need the same behavior in the editor and terminal. Is there any way to change this association? – nightcod3r Jun 21 '17 at 11:26
  • 1
    These shortcuts cannot be changed in gnome-terminal. – jimmij Jun 21 '17 at 11:39
2

It's a problem that has to be solved for each particular terminal. In the case of mlterm you add these lines to the shortcuts file ~/.mlterm/key:

Prior=PAGE_UP
Next=PAGE_DOWN

As for gnome-terminal and lxterminal, the preferences window does not allow to change this.

1

I use Shift+pgUP and Shift+pgDOWN. this key combination provides page scrolling.

I am using Ubuntu though.

1
  • 1
    But, where is this keybinding established and how to change it for a terminal? – nightcod3r Jun 21 '17 at 11:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.