4

I am thinking if it is possible to autofetch public keys for new recipients from the main gpg/pgp key servers. I was thinking about some setting in $HOME/.muttrc, studying here but did not find a conclusive setting for the target. I tried pgp_verify_sig there but my Mutt says source: errors in /home/users/leo/.muttrc, so implying me that it is not the correct parameter to autofetch public keys from the main key servers. Pseudocode

  1. define main key servers if necessary
  2. set autofetch of public keys for the senders from the key servers

Common view in my Mutt

[-- PGP output follows (current time: Wed 21 Jun 2017 10:52:06 AM EEST) --]
gpg: Signature made Wed 21 Jun 2017 10:51:18 AM EEST using RSA key ID ....
gpg: Can't check signature: public key not found
[-- End of PGP output --]

[-- The following data is signed --]

Testing SD Allen's proposal

Code in $HOME/.gnupg/gpg.conf

keyserver hkp://keys.gnupg.net
keyserver-options auto-key-retrieve
# Automatically verify the sign of a message when opened
set crypt_verify_sig=yes

Output: still same failed output PGP signature could NOT be verified in Mutt

OS: Debian 8.7

1 Answer 1

3

In order to do this, add this line to your ~/.gnupg/gpg.conf file:

keyserver <keyserver address> keyserver-options auto-key-retrieve

5
  • It doesn't autofetch with the above setup?
    – SD Allen
    Commented Jun 24, 2017 at 11:49
  • 1
    I assume it has to fetch the signature to verify it: #automatically verify the sign of a message when opened set crypt_verify_sig=yes If not: this should help:
    – SD Allen
    Commented Jun 24, 2017 at 11:55
  • Well, the only other thing I can think of: does your system muttrc file have an entry voiding commands in ~/.muttrc? On my system I have at 'Muttrc' & Muttrc.d in /etc which are sourced before the home '.muttrc'. Sorry, the only other thing I can think of. ¯_(ツ)_/¯
    – SD Allen
    Commented Jun 25, 2017 at 12:03
  • Comment them out? What I'm saying is, ensure that your system muttrc isn't interfering. One of the 1st things to check and you haven't told us if you have.
    – SD Allen
    Commented Jun 26, 2017 at 12:34
  • If you're running a debian system they'll be there by default. Just comment the commands out that you don't want interfering. I'm beginning to wonder if you're trolling here or what?
    – SD Allen
    Commented Jun 27, 2017 at 11:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .