0

I'm dealing with some strange UEFI problems and right now the only thing I seem to be able to boot is openSUSE Tumbleweed on a live USB stick (KDE version, snapshot 20170608 x64).

Background: I'm dealing with a Toshiba Satellite S55t-B5233 laptop. I wanted to reinstall Windows 10, but when I installed it, it did not properly wipe the partition and I ended up with the option to boot "Windows 10" or "Windows 10" when I started up. I booted up an openSUSE live image, deleted every partition on the drive, created a new, blank EFI system partition with a FAT filesystem, and then my troubles began. I could not boot from anything, including USB sticks that had literally worked less than an hour or so before. Finally, I was able to boot from the openSUSE live USB after holding down the "U" key. I tried installing openSUSE to the disk, but that didn't work. I've tried a true openSUSE install image on a USB drive (not the live image), Archiso on a USB drive, the rEFInd live USB image, and a Windows 10 installer made with Rufus. None of them work—all I get is a "No bootable device -- Please restart system". (I even tried changing the MBR disk identifier of the Arch drive to match the openSUSE one. That didn't work either.) Anyway, onto my real question. (In the context of the openSUSE live environment)

efibootmgr --verbose lists "Windows Boot Manager" as an entry in the UEFI boot options. It also specifies a file path to bootmgfw.efi, which no longer exists on the drive. When I use efibootmgr -b 3 -B I get Could not delete variable: Interrupted system call. The file for Boot0003 disappears from /sys/firmware/efi/efivars, and efibootmgr says that no BootOrder is set, but upon rebooting both variables return to their previous state. I think that the changes to the efivars filesystem aren't actually being written to the firmware, so does that indicate a bug with openSUSE, or does it mean a problem with the firmware?

EDIT: Using the GRUB command line, I booted into Arch Linux. The same problem continued.

0

EDIT: this was a case of the intel_spi_platform driver bug that was rather well publicized recently for Ubuntu, though in this case it was caused by openSUSE. The damage was reversible by following installing Linux kernel 4.14.10 via UKUU (Ubuntu Kernel Upgrade Utility). I imagine that the patched version of Linux 4.15.x recommended by the above-linked bug report would also have worked.

I have done pretty much all I can, and my research indicates that the NVRAM is pretty much toast. I modified openSUSE live USB to let me run the EFI Shell from Archiso, and even after trying both bcfg and dmpstore commands in both EFI shell v1 and v2, I cannot delete that boot entry. I may try to install Windows to match that existing entry since I can chainload from the EFI shell. Maybe.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.