1

I have Lubuntu 17.04 with i3 as a window manager. For some reason, after 10 minutes the PC goes to sleep even while I am watching online videos like Youtube. I have tried several things, primarily logging out of i3 and logging into LXDE, unchecking all the screen saver, power saver, sleep etc. options but nothing helps. I was wondering if someone can direct me to the solution?

1

This nightmare is called Light Locker and is set by default, can be although modified under preferences.

enter image description here

| improve this answer | |
  • you're not going to believe it but today when I run my PC the problem was back. I run light-locker-settings to see what was the problem, and found that the old settings were back. I manually set everything back again but I'm sure when I reboot the system it will be back.How can I permanently kill it? – Oposum Jun 22 '17 at 1:36
  • I didn't test this by myself, but can you try to disable system-wide startup of light-locker: sudo mv /etc/xdg/autostart/light-locker.desktop /etc/xdg/autostart/light-locker.desktop.backup? If you want to re-enable it just rename it back to its original name. Did it work properly? – marc Jun 22 '17 at 18:20
  • tried it, still does the same thing but this time it happened after 17 min. So this far the only failsafe way is to have the light locker installed and after every reboot set the preferences to never turn the screen off. – Oposum Jun 23 '17 at 2:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.