The guide recommends the Gufw firewall GUI. I installed it by apt

gufw/oldstable,oldstable,now 12.10.0-1 all [installed]
  graphical user interface for ufw

Typing ẁindow key + gufw, I cannot see the application. Only access is through terminal by gufw which is not enough. I am thinking why so + how to fix the issue because I am systematically using too little firewall in Linux.

Installation and testing the packages installed

  1. Studying the package masi@masi:$ apt search gufw

    Sorting... Done
    Full Text Search... Done
    gufw/oldstable,oldstable,now 12.10.0-1 all [installed]
      graphical user interface for ufw
  2. Installation by method apt install gufw

  3. Output of apt show -a gufw where I am thinking about two packages (17.04 and 12.10) so something conflicting in my system - for some reason gufw in terminal starts gufw 12.10

    Package: gufw
    Source: gui-ufw
    Version: 17.04.1-1.1
    Installed-Size: 3,376 kB
    Maintainer: Python Applications Packaging Team <python-apps-team@lists.alioth.debian.org>
    Depends: python3:any (>= 3.3.2-2~), ufw (>= 0.34~rc), gir1.2-gtk-3.0, policykit-1, gir1.2-webkit2-4.0, python3-gi, net-tools
    Homepage: http://gufw.org/
    Tag: admin::configuring, implemented-in::python, interface::graphical,
     interface::x11, network::firewall, role::program, scope::utility,
     security::firewall, uitoolkit::gtk, use::configuring, x11::application
    Section: admin
    Priority: optional
    Download-Size: 842 kB
    APT-Sources: http://ftp.fr.debian.org/debian/ unstable/main amd64 Packages
    Package: gufw
    Source: gui-ufw
    Version: 12.10.0-1
    Installed-Size: 1,328 kB
    Maintainer: Devid Antonio Filoni <d.filoni@ubuntu.com>
    Depends: python (>= 2.6.6-7~), ufw (>= 0.31.1), gir1.2-gtk-3.0, gir1.2-polkit-1.0, notify-osd | notification-daemon, policykit-1, python-dbus, python-gobject, gnome-icon-theme-symbolic
    Homepage: https://launchpad.net/gui-ufw
    Tag: admin::configuring, implemented-in::python, interface::x11,
     network::firewall, role::program, scope::utility, security::firewall,
     uitoolkit::gtk, use::configuring, x11::application
    Section: admin
    Priority: optional
    Download-Size: 261 kB
    APT-Manual-Installed: yes
    APT-Sources: http://ftp.fi.debian.org/debian/ jessie/main amd64 Packages
  4. Output of apt-cache policy gufw

      Installed: 12.10.0-1
      Candidate: 12.10.0-1
      Version table:
          17.04.1-1.1 0
            200 http://ftp.fr.debian.org/debian/ unstable/main amd64 Packages
      *** 12.10.0-1 0
            500 http://ftp.fi.debian.org/debian/ jessie/main amd64 Packages
            500 http://httpredir.debian.org/debian/ jessie/main amd64 Packages
            100 /var/lib/dpkg/status
  5. Output of dpkg -l gufw

     | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
     |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
     ||/ Name                            Version              Architecture         Description
     ii  gufw                            12.10.0-1            all                  graphical user interface for ufw

I do the following and get sudo apt -t unstable install gufw

[sudo] password for masi: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gsettings-desktop-schemas : Breaks: gnome-settings-daemon (< 3.19.92) but 3.14.2-3+deb8u1 is to be installed
                             Breaks: mutter (< 3.19.92) but 3.14.4-1~deb8u1 is to be installed
 gstreamer1.0-plugins-base : Breaks: gstreamer1.0-plugins-bad (< 1.11.90) but 1.4.4-2.1+deb8u2 is to be installed
 libgstreamer-plugins-base1.0-0 : Breaks: gstreamer1.0-plugins-bad (< 1.7.1) but 1.4.4-2.1+deb8u2 is to be installed
 libgstreamer1.0-0 : Breaks: gstreamer1.0-plugins-bad (< 1.11.1) but 1.4.4-2.1+deb8u2 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

OS: Debian 8.7
Related bug: gufw: desktop entry doesn't show up in desktop environments

  • 1
    Looks like a known bug: bugs.debian.org/cgi-bin/bugreport.cgi?bug=681315 – tripleee Jun 20 '17 at 17:41
  • @tripleee Please, see the body. apt shows me two packages existing for gufw. Typing gufw in terminal opens the older version 12.10. What do you think? – Léo Léopold Hertz 준영 Jun 20 '17 at 18:37
  • 1
    You can only have one version so I guess that's the old one. Nothing here tells us why. Can you show the output of apt-cache policy gufw and perhaps for completeness dpkg -l gufw? – tripleee Jun 20 '17 at 18:55
  • 1
    Did you try apt -t unstable install gufw? – tripleee Jul 1 '17 at 10:36
  • 1
    Welp, it depends on some packages which appear to be unsafe to upgrade. You can try to force it (and possibly end up upgrading significant portions of your system to unstable versions, at your peril) or see if it can somehow be made to work with dependencies ignored. (You probably have older versions of these packages; if you are lucky, they could just happen to work.) – tripleee Jul 2 '17 at 7:44

Debian Stretch was released a couple of weeks ago. Upgrading your entire system to that would seem like the easiest solution to your conundrum.

The bug was fixed in the version in Debian Stretch, while the old stable release Jessie was still stuck on a version from almost five years ago.

  • Correct answer! I awarded you the bounty. The Gufw is 17.04.1 in Debian 9. The search works as expected. Can you offe an explantation why there is no such problem in Debian 9 version? – Léo Léopold Hertz 준영 Jul 2 '17 at 7:53
  • Expanded the answer a bit. – tripleee Jul 2 '17 at 9:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.