I'm running Debian wheezy (x86) with GNOME on a Intel Core i7 machine. I'm having problems getting PulseAudio to work properly. Since GNOME 3 automatically installs PulseAudio I'm pretty much stuck with it.

When running ALSA mixer from the console, I get the following error message:

ALSA lib conf.c:3314:(snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.so
ALSA lib control.c:951:(snd_ctl_open_noupdate) Invalid CTL default
cannot open mixer: No such file or directory

The shared library does in fact exist (/usr/lib/i386-linux-gnu/alsa-lib/libasound_module_conf_pulse.so). I've done extensive googling on the issue and came up with no solution that actually works. One of the suggestions was to place the file in an alternative location, but this made no difference.

In addition, many programs that actually attempt to use PulseAudio fail to start. Another error message I've seen is:

mybox:/# pulseaudio
pulseaudio: symbol lookup error: /usr/lib/i386-linux-gnu/libsndfile.so.1: undefined symbol: vorbis_version_string

ALSA works just fine, but I actually have to deinstall PulseAudio before I can use the mixer to set the volume, after which I can reinstall it. Then, some software that I can force to use ALSA (like XBMC) will work.

The system contains both onboard Intel audio and nVidia HDMI sound drivers. I'm mostly interested in sound over HDMI right now if that matters:

mybox:/# aplay -L
    Discard all samples (playback) or generate zero samples (capture)
    PulseAudio Sound Server
    HDA Intel, ALC887 Analog
    Default Audio Device
    HDA Intel, ALC887 Analog
    Default Audio Device
    HDA Intel, ALC887 Analog
    Front speakers
    HDA Intel, ALC887 Analog
    4.0 Surround output to Front and Rear speakers
    HDA Intel, ALC887 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
    HDA Intel, ALC887 Analog
    5.0 Surround output to Front, Center and Rear speakers
    HDA Intel, ALC887 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
    HDA Intel, ALC887 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
    HDA Intel, ALC887 Digital
    IEC958 (S/PDIF) Digital Audio Output
    HDA NVidia, HDMI 0
    HDMI Audio Output
    HDA NVidia, HDMI 0
    HDMI Audio Output
    HDA NVidia, HDMI 0
    HDMI Audio Output
    HDA NVidia, HDMI 0
    HDMI Audio Output

I'm now completely at a loss what is wrong with my system. I haven't even messed with any of the settings yet, but I tried purging all the configuration and reinstalling just to be sure.

To me, these error messages look like the packages are broken, but it's been like this for weeks now and several new package versions have been released in the meantime.Does anyone have an idea what's wrong?


Some extra information requested by Jan Marek:

mybox:~# ldconfig -v | grep libasound
ldconfig: Can't stat /lib/i486-linux-gnu: No such file or directory
ldconfig: Can't stat /usr/lib/i486-linux-gnu: No such file or directory
ldconfig: Path `/lib/i386-linux-gnu' given more than once
ldconfig: Path `/usr/lib/i386-linux-gnu' given more than once
        libasound.so.2 -> libasound.so.2.0.0

It appears libasound_module_conf_pulse.so is not listed, even though the path /usr/lib/i386-linux-gnu` is searched. More than once even, apparently? I'm not sure why that is, here is the relevant configuration:

## /etc/ld.so.conf:


include /etc/ld.so.conf.d/*.conf

## /etc/ld.so.conf.d/i486-linux-gnu.conf:

# Multiarch support

## /etc/ld.so.conf.d/libc.conf

# libc default configuration

As for the strace, I'm not entirely sure what it's trying to tell me.

11655 open("/usr/lib/i386-linux-gnu/alsa-lib/libasound_module_conf_pulse.so", O_RDONLY) = 3
11655 read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0000\7\0\0004\0\0\0"..., 512) = 512
11655 fstat64(3, {st_mode=S_IFREG|0644, st_size=4168, ...}) = 0
11655 mmap2(NULL, 7028, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0xb7785000
11655 mmap2(0xb7786000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0) = 0xb7786000
11655 close(3) = 0

I think that means that opening the file was successful, it read 512 bytes and then decided to close the file?

I've added /usr/lib/i386-linux-gnu/alsa-lib to ld.so.conf which changes the behavior when I start alsamixer. With that line I get a segmentation fault instead. During the boot sequence I also used to get a bunch of these pulseaudio errors, so I will try rebooting when I get home (service alsasound restart had no effect)


1) When you try ldconfig -v: will be in this list libasound_module_conf_pulse.so library?

2) You can try command strace -f -F -o alsamixer.strace alsamixer, and then explore file alsamixer.strace and try to go from bottom to top and find, why it cannot open file with library.

| improve this answer | |
  • I've added the relevant command outputs to my original question. ldconfig doesn't list the library, but it does appear to be opened according to the strace. – Thorarin Apr 25 '12 at 8:38
  • 1
    strace says to you, that alsamixer loaded libasound_module_conf_pulse.so library and then opened it, tried to load 512B from it and then load it into memory (mmap2 call). I think, that there will be wrong somethink around a config file for pulseaudio. Please, can you add part of alsamixer.strace from loading a library to the end? – Jan Marek Apr 26 '12 at 7:26

Realtek ALC887 (HDA Intel) in Wheezy ?

I found this:


at the end of here:


good luck.

| improve this answer | |

You may need to install the 32-bit version if you are running a 32-bit app on a 64-bit system:

sudo dpkg --add-architecture i386
sudo apt-get install libasound2-plugins:i386
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.