0

I'm using Debian 9 Stretch Live from a USB Stick for testing hardware compatibility.

The firmeware for the Intel Wireless 2230 was not included in the Live image. Therefore I installed it offline from Binary firmware for Intel Wireless cards with

sudo dpkg -i firmware-iwlwifi_20161130-3_all.deb

After that I reinsert the Wifi module with

sudo modprobe -r iwlwifi ; sudo modprobe iwlwifi

The wifi adapter showed up in gnomes network manager and I could access my wlan. IP and subnet was correct via DHCP.

But I cannot ping hostnames like

ping google.com

I get 'hostname not found'. Ping via IP works fine and I receive packages

ping 8.8.8.8

I changed '/etc/resolve.conf' to use 8.8.8.8 and 8.8.4.4 as nameservers and restarted networking with

/etc/init.d/networking restart

I also tried

sudo resolvconf -u

without success.

At normal conditions a restart solved my issue. But with a Live Image a restart is a bit... repeating ; -)

Has someone an idea where I get wrong?

0

Normally to get iwlwifi to work you HAVE to reboot.

BUT which ISO did you use? The official one which has "main" only? Where did you get it from? Can you provide a link.

You could try the unofficial live+non-free, which includes the firmware, from here: https://cdimage.debian.org/cdimage/unofficial/non-free/cd-including-firmware/9.0.0-live+nonfree/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.