0

Let's suppose I have a user called user1 and his home directory is on: /home/user1. All files on that directory need to be 750 (chmod -R 750 /home/user1).

I installed vsftpd so I can manage my files easy, but there's one problem, if I chmod 750 all files inside that directory, I can't log in via FTP because of this error: 500 OOPS: vsftpd: refusing to run with writable root inside chroot ()

To solve that error I have to chmod a-w the whole directory (chmod a-w /home/user1) but then I can't start some files that I have inside that directory (and that is fixed using 750 permissions).

I have 3 users so I have to jail them inside their home directories. Note that allowing writable root is not a good option, as I don't want users to get out of their home directories.

Is there any way to fix this? Thanks!

0

If you want to have writeable root directories then you need to enable the following option:

allow_writeable_chroot=YES

https://wiki.archlinux.org/index.php/Very_Secure_FTP_Daemon

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.