6

I just switched to Debian following the recent release of version 9. I do a lot of work with RStudio and thus tried to install the stable and testing versions which both failed due to the missing library "libgstreamer0.10-0". It appears that a more recent version of that package is installed but 0.10-0 is not available in stretch. Is there a way to install RStudio despite the missing package? Help is much appreciated. Apologies if this is not the right place to ask this question.

OS: Debian 9
RStudio: 1.0.143-amd64

Edit:

Installation was performed using gdebi.

Edit 2:

After installing libgstreamer0.10 and libgstreamer-base-0.10 as described in the linked question I now get libssl1.0.0 as a not satisfiable dependency in gdebi.

Edit 3:

Get lissl1.0.0 from here and install. After that Rstudio installs and runs fine (I'll report back if I encounter problems).

5
  • What is your Rstudio version? - - Please, see stackoverflow.com/a/43586708/54964 Jun 25, 2017 at 16:26
  • Please, describe how you installed RStudio. I think I have had this problem before and there is a solution to it. Jun 25, 2017 at 16:39
  • I just downloaded the latest deb package from their website and tried to install it using gdebi. It said that the dependencies could not be met naming the above-mentioned package. Jun 25, 2017 at 17:01
  • 1
    I tried the accepted solution of the question you linked. That seems to satisfy the libgstreamer situation but now it requires libssl1.0.0 which seems to be libssl1.0.2 in stretch. At this point I think I'll just wait until Rstudio gets updated to not depend out of date software. I'm not super comfortable installing and holding a lot of libraries I don't fully understand. Jun 25, 2017 at 17:13
  • Yes, that should also be an easy problem with libssl1.0.0, since I think I have had it too. RStudio is already well updated and should work fine in your system too. Please, do not leave this thread a stub. - - Please, provide me the logs what you get now with libssl.... Jun 25, 2017 at 17:42

3 Answers 3

3

An updated version of RStudio is available for Ubuntu 16.04+ and Debian 9+ (both 64-bit only) on their download page.

Using this version, installation runs smoothly with sudo gdebi rstudio-xenial-1.1.350-amd64.deb on Debian 9.1. :)

1
  • This is indeed working on Debian, and seems the most straightforward answer.
    – mhermans
    Aug 15, 2018 at 13:30
0

I think RStudio 1.0.143 is sufficient for Debian 9. You just have to fix a few packges there. Do and please report us what you get from step (2)

  1. Fix libgstreamer0.10-0 problem as described in the thread here
  2. Fix libssl1.0.0 problem.

    Download libssl1.0.0 from here

  3. Install libssl1.0.0, install Rstudio

  4. Enjoy Rstudio ;)

3
  • 1
    edited question Jun 25, 2017 at 17:47
  • @DanielWinkler Can you provide a complete log? - - I really have had the same error with libssl1.0.0 and it is a direct fix/solution to the problem. Jun 25, 2017 at 17:50
  • 1
    I don't know how to get the log from gdebi. It just says that the dependency cannot be met. But installing libssl1.0.0 will fix it. Thanks for your help! Jun 25, 2017 at 17:54
0

Alternative Answer:

  1. Install libgstreamer0.10-0 & libgstreamer-plugins-base0.10-0 according to the accepted answer here
  2. cd into the directory with the rstudio deb file and Run (replace XXX with package version):

    dpkg --ignore-depends=libssl1.0.0 -i rstudio-1.0.XXX-amd64.deb
    
  3. Run (replace nano with your editor if you feel like it):

    sudo nano /var/lib/dpkg/status
    
  4. Find the rstudio entry and delete libssl1.0.0 from the Depends: ... line

  5. Enjoy Rstudio

References:

Ignore dependencies while installing

Ingnore Broken Packages

2
  • I visited the link you left in the first point, but I did better following this answer (which is the currently accepted one, as I write this) than the one you suggested. I basically downloaded the preview R package, installed and then run it.
    – Acsor
    Jul 18, 2017 at 16:29
  • That is great. Preview didn't work yet when I wrote the answer. Or at least I failed to run it. Jul 18, 2017 at 16:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.