2

I wonder if someone can help me sort through my situation.

So I'm keeping my system up-to-date today using the documented Debian process:

  • sudo apt-get update
  • sudo apt-get dist-upgrade

The latter step is unable to complete due to package issues:

$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 exim4-base : Breaks: exim4-daemon-light (< 4.89) but 4.84.2-2+deb8u3 is to be installed
 exim4-config : Breaks: exim4-daemon-light (< 4.87~RC5) but 4.84.2-2+deb8u3 is to be installed
 gnome-shell-common : Breaks: gnome-tweak-tool (< 3.21.91) but 3.14.2-2 is to be installed
 vlc-bin : Breaks: vlc-nox (< 2.2.6-1~deb9u1) but 2.2.5-1~deb8u1 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

I considered repairing this situation as per a similar solution in Ubuntu. That is to try to remove each of the above three problematic packages. But gnome-tweak-tool and vlc-nox, apparently cannot be removed without removing a great deal of my system, including aptitude itself, apparently:

$ sudo apt-get remove gnome-tweak-tool
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  gir1.2-gtk-2.0 gir1.2-javascriptcoregtk-4.0 gir1.2-rb-3.0 gnome-software-common libavcodec-dev libavcodec57 libavformat-dev libavresample-dev libavutil-dev
  libavutil55 libboost-atomic-dev libboost-atomic1.55-dev libboost-atomic1.55.0 libboost-atomic1.62.0 libboost-chrono-dev libboost-chrono1.55-dev
  libboost-chrono1.55.0 libboost-chrono1.62.0 libboost-context-dev libboost-context1.55-dev libboost-context1.55.0 libboost-coroutine-dev libboost-coroutine1.55-dev
  libboost-date-time1.62.0 libboost-dev libboost-exception-dev libboost-exception1.55-dev libboost-filesystem-dev libboost-filesystem1.55-dev
  libboost-filesystem1.55.0 libboost-filesystem1.62.0 libboost-graph-dev libboost-graph-parallel1.62.0 libboost-graph1.55-dev libboost-graph1.55.0
  libboost-iostreams-dev libboost-iostreams1.55-dev libboost-iostreams1.62.0 libboost-locale-dev libboost-locale1.55-dev libboost-locale1.55.0 libboost-log1.62.0
  libboost-math-dev libboost-math1.55-dev libboost-math1.55.0 libboost-mpi-python1.62.0 libboost-mpi1.62.0 libboost-program-options-dev
  libboost-program-options1.55-dev libboost-program-options1.55.0 libboost-python-dev libboost-python1.55-dev libboost-python1.55.0 libboost-python1.62.0
  libboost-random-dev libboost-random1.55-dev libboost-random1.55.0 libboost-regex-dev libboost-regex1.55-dev libboost-regex1.55.0 libboost-regex1.62.0
  libboost-serialization-dev libboost-serialization1.55-dev libboost-serialization1.55.0 libboost-serialization1.62.0 libboost-signals-dev libboost-signals1.55-dev
  libboost-signals1.55.0 libboost-system-dev libboost-system1.55-dev libboost-system1.62.0 libboost-test-dev libboost-test1.55-dev libboost-test1.55.0
  libboost-test1.62.0 libboost-thread1.62.0 libboost-timer-dev libboost-timer1.55-dev libboost-timer1.55.0 libboost-timer1.62.0 libboost-tools-dev libboost-wave1.62.0
  libboost1.55-dev libboost1.55-tools-dev libchromaprint1 libcr0 libcwidget3v5 libdc1394-22-dev libegl1-mesa-drivers libfabric1 libgrilo-0.3-0 libgtk2.0-dev
  libhwloc-dev libhwloc-plugins libhwloc5 libibverbs-dev libibverbs1 libinput-bin libinput10 libjavascriptcoregtk-4.0-18 liblz4-1 libnuma-dev libnuma1
  libopencv-core-dev libopencv-core2.4v5 libopencv-flann-dev libopencv-flann2.4v5 libopencv-imgproc-dev libopencv-imgproc2.4v5 libopencv-ml-dev libopencv-ml2.4v5
  libopencv-photo-dev libopencv-photo2.4v5 libopencv-video-dev libopencv-video2.4v5 libopenjp2-7 libopenmpi-dev libopenmpi2 libpoppler64 libpotrace0
  libpsm-infinipath1 libraw1394-dev libraw1394-tools librdmacm1 libsnappy1v5 libsoxr0 libswresample2 libswscale-dev libvpx4 libwebp6 libwebpmux2 libx264-148
  libx265-95 libxapian30 libxcb-res0 mpi-default-bin mpi-default-dev opencv-data openmpi-bin openmpi-common
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  appstream aptitude-common at-spi2-core baobab dbus gcc-6-base gedit gedit-common gedit-plugins gir1.2-gtk-3.0 gir1.2-packagekitglib-1.0 gir1.2-pango-1.0
  gir1.2-rb-3.0 gparted libapparmor1 libappstream4 libatk-adaptor libatkmm-1.6-1v5 libavcodec57 libavutil55 libboost-date-time1.62.0 libboost-filesystem1.62.0
  libboost-iostreams1.62.0 libboost-system1.62.0 libcairomm-1.0-1v5 libchromaprint1 libcwidget3v5 libdbus-1-3 libdbus-1-dev libdrm-amdgpu1 libdrm-dev libegl1-mesa
  libegl1-mesa-dev libepoxy-dev libexempi3 libfabric1 libgail-3-0 libgdm1 libglibmm-2.4-1v5 libgraphite2-dev libgrilo-0.3-0 libgspell-1-1 libgspell-1-common
  libgtk-3-0 libgtk-3-dev libgtkmm-2.4-1v5 libgtksourceview-3.0-1 libharfbuzz-dev libharfbuzz-gobject0 libharfbuzz-icu0 libharfbuzz0b libicu57 libinput-bin libinput10
  libjavascriptcoregtk-4.0-18 liblirc-client0 liblircclient0 liblz4-1 libopencv-core-dev libopencv-core2.4v5 libopencv-flann-dev libopencv-flann2.4v5
  libopencv-imgproc-dev libopencv-imgproc2.4v5 libopencv-ml-dev libopencv-ml2.4v5 libopencv-photo-dev libopencv-photo2.4v5 libopencv-video-dev libopencv-video2.4v5
  libopenjp2-7 libopenmpi-dev libopenmpi2 libpackagekit-glib2-18 libpango-1.0-0 libpango1.0-0 libpango1.0-dev libpangocairo-1.0-0 libpangoft2-1.0-0 libpangomm-1.4-1v5
  libpangoxft-1.0-0 libpeas-1.0-0 libpng16-16 libpoppler64 libpotrace0 libpsm-infinipath1 libpython3-stdlib libpython3.5 libpython3.5-minimal libpython3.5-stdlib
  librdmacm1 libreadline7 librhythmbox-core10 libsigc++-2.0-0v5 libsnappy1v5 libsoxr0 libssl1.1 libstdc++6 libstemmer0d libswresample2 libvpx4 libwacom-common
  libwacom2 libwayland-bin libwayland-client0 libwayland-cursor0 libwayland-dev libwayland-egl1-mesa libwayland-server0 libwebp6 libwebpmux2 libx11-xcb-dev
  libx264-148 libx265-95 libxapian30 libxcb-dri2-0-dev libxcb-dri3-dev libxcb-glx0-dev libxcb-present-dev libxcb-randr0-dev libxcb-shape0-dev libxcb-sync-dev
  libxcb-xfixes0-dev libxshmfence-dev libxxf86vm-dev libyaml-0-2 light-locker openmpi-bin openmpi-common powertop python3 python3-brlapi python3-cairo python3-dbus
  python3-gi python3-gi-cairo python3-markupsafe python3-minimal python3.5 python3.5-minimal rhythmbox rhythmbox-data rhythmbox-plugin-cdrecorder task-desktop
  task-english task-laptop task-xfce-desktop tasksel tasksel-data udisks2 wayland-protocols x11proto-dri2-dev x11proto-gl-dev x11proto-xf86vidmode-dev
Suggested packages:
  xfsprogs reiserfsprogs reiser4progs jfsutils mtools kpartx dmraid gpart libcwidget-dev grilo-plugins-0.3 libgtk-3-doc lirc openmpi-doc libpango1.0-doc xapian-tools
  gfortran cpufrequtils laptop-mode-tools python3-doc python3-tk python3-venv python-dbus-doc python3-dbus-dbg python3.5-venv python3.5-doc binfmt-support
  gnome-codec-install btrfs-progs btrfs-tools cryptsetup-bin mdadm
Recommended packages:
  libwacom-bin libreoffice-gtk2 exfat-utils
The following packages will be REMOVED:
  aptitude cheese empathy evolution evolution-data-server evolution-plugins gdebi-core gdm3 gnome gnome-contacts gnome-control-center gnome-core gnome-packagekit
  gnome-packagekit-session gnome-session gnome-shell gnome-shell-extension-weather gnome-shell-extensions gnome-system-monitor gnome-tweak-tool gnome-video-effects
  gstreamer1.0-plugins-bad inkscape libatkmm-1.6-1 libboost-all-dev libboost-date-time-dev libboost-date-time1.55-dev libboost-date-time1.55.0
  libboost-graph-parallel-dev libboost-graph-parallel1.55-dev libboost-graph-parallel1.55.0 libboost-log-dev libboost-log1.55-dev libboost-log1.55.0 libboost-mpi-dev
  libboost-mpi-python-dev libboost-mpi-python1.55-dev libboost-mpi-python1.55.0 libboost-mpi1.55-dev libboost-mpi1.55.0 libboost-thread-dev libboost-thread1.55-dev
  libboost-wave-dev libboost-wave1.55-dev libboost-wave1.55.0 libcairomm-1.0-1 libcheese-gtk23 libcheese7 libcmis-0.4-4 libcv-dev libcvaux-dev libcwidget3
  libebook-1.2-14 libebook-contacts-1.2-0 libedata-book-1.2-20 libevolution libfarstream-0.2-2 libfolks-eds25 libglibmm-2.4-1c2a libgtkmm-2.4-1c2a libgtkmm-3.0-1
  libhighgui-dev libopencv-calib3d-dev libopencv-calib3d2.4 libopencv-contrib-dev libopencv-contrib2.4 libopencv-core2.4 libopencv-dev libopencv-features2d-dev
  libopencv-features2d2.4 libopencv-flann2.4 libopencv-gpu-dev libopencv-gpu2.4 libopencv-highgui-dev libopencv-highgui2.4 libopencv-imgproc2.4 libopencv-legacy-dev
  libopencv-legacy2.4 libopencv-ml2.4 libopencv-objdetect-dev libopencv-objdetect2.4 libopencv-ocl-dev libopencv-ocl2.4 libopencv-photo2.4 libopencv-stitching-dev
  libopencv-stitching2.4 libopencv-superres-dev libopencv-superres2.4 libopencv-ts-dev libopencv-ts2.4 libopencv-video2.4 libopencv-videostab-dev
  libopencv-videostab2.4 libopencv2.4-java libopencv2.4-jni libopenmpi1.6 libpangomm-1.4-1 libphonenumber6 libreoffice libreoffice-avmedia-backend-gstreamer
  libreoffice-base libreoffice-base-core libreoffice-base-drivers libreoffice-calc libreoffice-core libreoffice-draw libreoffice-evolution libreoffice-gnome
  libreoffice-gtk libreoffice-help-en-us libreoffice-impress libreoffice-math libreoffice-report-builder-bin libreoffice-sdbc-firebird libreoffice-sdbc-hsqldb
  libreoffice-writer libsigc++-2.0-0c2a libtelepathy-farstream3 mythes-en-us packagekit packagekit-tools python-opencv python3-apt python3-pil
  python3-software-properties python3-uno rhythmbox-plugins software-properties-common task-gnome-desktop totem totem-plugins unattended-upgrades unoconv
The following NEW packages will be installed:
  appstream gcc-6-base libapparmor1 libappstream4 libatkmm-1.6-1v5 libavcodec57 libavutil55 libboost-date-time1.62.0 libboost-filesystem1.62.0
  libboost-iostreams1.62.0 libboost-system1.62.0 libcairomm-1.0-1v5 libchromaprint1 libcwidget3v5 libdrm-amdgpu1 libdrm-dev libegl1-mesa-dev libepoxy-dev libfabric1
  libglibmm-2.4-1v5 libgraphite2-dev libgrilo-0.3-0 libgspell-1-1 libgspell-1-common libgtkmm-2.4-1v5 libicu57 libinput-bin libinput10 libjavascriptcoregtk-4.0-18
  liblirc-client0 liblz4-1 libopencv-core2.4v5 libopencv-flann2.4v5 libopencv-imgproc2.4v5 libopencv-ml2.4v5 libopencv-photo2.4v5 libopencv-video2.4v5 libopenjp2-7
  libopenmpi2 libpangomm-1.4-1v5 libpng16-16 libpoppler64 libpotrace0 libpsm-infinipath1 libpython3.5 libpython3.5-minimal libpython3.5-stdlib librdmacm1 libreadline7
  librhythmbox-core10 libsigc++-2.0-0v5 libsnappy1v5 libsoxr0 libssl1.1 libstemmer0d libswresample2 libvpx4 libwayland-bin libwebp6 libwebpmux2 libx11-xcb-dev
  libx264-148 libx265-95 libxapian30 libxcb-dri2-0-dev libxcb-dri3-dev libxcb-glx0-dev libxcb-present-dev libxcb-randr0-dev libxcb-shape0-dev libxcb-sync-dev
  libxcb-xfixes0-dev libxshmfence-dev libxxf86vm-dev libyaml-0-2 light-locker python3.5 python3.5-minimal wayland-protocols x11proto-dri2-dev x11proto-gl-dev
  x11proto-xf86vidmode-dev
The following packages will be upgraded:
  aptitude-common at-spi2-core baobab dbus gedit gedit-common gedit-plugins gir1.2-gtk-3.0 gir1.2-packagekitglib-1.0 gir1.2-pango-1.0 gir1.2-rb-3.0 gparted
  libatk-adaptor libdbus-1-3 libdbus-1-dev libegl1-mesa libexempi3 libgail-3-0 libgdm1 libgtk-3-0 libgtk-3-dev libgtksourceview-3.0-1 libharfbuzz-dev
  libharfbuzz-gobject0 libharfbuzz-icu0 libharfbuzz0b liblircclient0 libopencv-core-dev libopencv-flann-dev libopencv-imgproc-dev libopencv-ml-dev libopencv-photo-dev
  libopencv-video-dev libopenmpi-dev libpackagekit-glib2-18 libpango-1.0-0 libpango1.0-0 libpango1.0-dev libpangocairo-1.0-0 libpangoft2-1.0-0 libpangoxft-1.0-0
  libpeas-1.0-0 libpython3-stdlib libstdc++6 libwacom-common libwacom2 libwayland-client0 libwayland-cursor0 libwayland-dev libwayland-egl1-mesa libwayland-server0
  openmpi-bin openmpi-common powertop python3 python3-brlapi python3-cairo python3-dbus python3-gi python3-gi-cairo python3-markupsafe python3-minimal rhythmbox
  rhythmbox-data rhythmbox-plugin-cdrecorder task-desktop task-english task-laptop task-xfce-desktop tasksel tasksel-data udisks2
72 upgraded, 82 newly installed, 133 to remove and 616 not upgraded.
Need to get 68.0 MB of archives.
After this operation, 360 MB disk space will be freed.
Do you want to continue? [Y/n] 

Can somebody help me make sense of this? I will not perform the operation yet.

I should say in passing that my apt sources is not vanilla: around a week ago I followed this ServerFault post to enable a couple of non-stable packages. None of the packages in the dist-upgrade error above (exim4-daemon-light, gnome-tweak-tool, or vlc-nox) have been installed since this configuration was put in place, however.

Following are each of the changes I made to those /etc/apt sources.list and pinning preference files (commented lines removed):

pinning preferences

/etc/apt/preferences.d$ ls
experimental.pref  security.pref  stable.pref  testing.pref  unstable.pref
/etc/apt/preferences.d$ cat *
Package: *
Pin: release a=experimental
Pin-Priority: 1
Package: *
Pin: release l=Debian-Security
Pin-Priority: 1000
Package: *
Pin: release a=stable
Pin-Priority: 900
Package: *
Pin: release a=testing
Pin-Priority: 750
Package: *
Pin: release a=unstable
Pin-Priority: 50

sources.list

deb http://ftp.us.debian.org/debian/ jessie main
deb-src http://ftp.us.debian.org/debian/ jessie main
deb http://security.debian.org/ jessie/updates main
deb-src http://security.debian.org/ jessie/updates main
deb http://ftp.us.debian.org/debian/ jessie-updates main
deb-src http://ftp.us.debian.org/debian/ jessie-updates main
deb [arch=amd64] https://download.docker.com/linux/debian jessie stable

sources.list.d/dropbox.list

deb [arch=i386,amd64] http://linux.dropbox.com/debian jessie main

sources.list.d/experimental.list

deb http://mirror.steadfast.net/debian/ experimental main contrib non-free
deb-src http://mirror.steadfast.net/debian/ experimental main contrib non-free
deb http://ftp.us.debian.org/debian/ experimental main contrib non-free
deb-src http://ftp.us.debian.org/debian/ experimental main contrib non-free

sources.list.d/google-chrome.list

deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main

sources.list.d/security.list

deb http://security.debian.org/ stable/updates main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free

sources.list.d/sources.list

# Lines commented out, due to causing apt-get upgrade problems
# conflicting with other files in this directory.
# Left here for archiving.
#
#
#
# Debian packages for stable
# deb http://ftp.us.debian.org/debian/ stable main contrib
# Uncomment the deb-src line if you want 'apt-get source'
# to work with most packages.
# deb-src http://ftp.us.debian.org/debian/ stable main contrib
# Security updates for stable
# deb http://security.debian.org/ stable/updates main contrib

sources.list.d/stable.list

deb http://mirror.steadfast.net/debian/ stable main contrib non-free
deb-src http://mirror.steadfast.net/debian/ stable main contrib non-free
deb http://ftp.us.debian.org/debian/ stable main contrib non-free
deb-src http://ftp.us.debian.org/debian/ stable main contrib non-free

sources.list.d/testing.list

deb http://mirror.steadfast.net/debian/ testing main contrib non-free
deb-src http://mirror.steadfast.net/debian/ testing main contrib non-free
deb http://ftp.us.debian.org/debian/ testing main contrib non-free
deb-src http://ftp.us.debian.org/debian/ testing main contrib non-free

sources.list.d/thomas_tsai-ubuntu-tuxboot-jessie.list

# (empty)

sources.list.d/unstable.list

deb http://mirror.steadfast.net/debian/ unstable main contrib non-free
deb-src http://mirror.steadfast.net/debian/ unstable main contrib non-free
deb http://ftp.us.debian.org/debian/ unstable main contrib non-free
deb-src http://ftp.us.debian.org/debian/ unstable main contrib non-free

Here is my apt-cache policy output:

$ sudo apt-cache policy
Package files:
 100 /var/lib/dpkg/status
     release a=now
 500 http://ftp.us.debian.org/debian/ unstable/non-free Translation-en
 500 http://ftp.us.debian.org/debian/ unstable/main Translation-en
 500 http://ftp.us.debian.org/debian/ unstable/contrib Translation-en
  50 http://ftp.us.debian.org/debian/ unstable/non-free amd64 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=non-free
     origin ftp.us.debian.org
  50 http://ftp.us.debian.org/debian/ unstable/contrib amd64 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=contrib
     origin ftp.us.debian.org
  50 http://ftp.us.debian.org/debian/ unstable/main amd64 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=main
     origin ftp.us.debian.org
 500 http://mirror.steadfast.net/debian/ unstable/non-free Translation-en
 500 http://mirror.steadfast.net/debian/ unstable/main Translation-en
 500 http://mirror.steadfast.net/debian/ unstable/contrib Translation-en
  50 http://mirror.steadfast.net/debian/ unstable/non-free amd64 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=non-free
     origin mirror.steadfast.net
  50 http://mirror.steadfast.net/debian/ unstable/contrib amd64 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=contrib
     origin mirror.steadfast.net
  50 http://mirror.steadfast.net/debian/ unstable/main amd64 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=main
     origin mirror.steadfast.net
 500 http://ftp.us.debian.org/debian/ testing/non-free Translation-en
 500 http://ftp.us.debian.org/debian/ testing/main Translation-en
 500 http://ftp.us.debian.org/debian/ testing/contrib Translation-en
 750 http://ftp.us.debian.org/debian/ testing/non-free amd64 Packages
     release o=Debian,a=testing,n=buster,l=Debian,c=non-free
     origin ftp.us.debian.org
 750 http://ftp.us.debian.org/debian/ testing/contrib amd64 Packages
     release o=Debian,a=testing,n=buster,l=Debian,c=contrib
     origin ftp.us.debian.org
 750 http://ftp.us.debian.org/debian/ testing/main amd64 Packages
     release o=Debian,a=testing,n=buster,l=Debian,c=main
     origin ftp.us.debian.org
 500 http://mirror.steadfast.net/debian/ testing/non-free Translation-en
 500 http://mirror.steadfast.net/debian/ testing/main Translation-en
 500 http://mirror.steadfast.net/debian/ testing/contrib Translation-en
 750 http://mirror.steadfast.net/debian/ testing/non-free amd64 Packages
     release o=Debian,a=testing,n=buster,l=Debian,c=non-free
     origin mirror.steadfast.net
 750 http://mirror.steadfast.net/debian/ testing/contrib amd64 Packages
     release o=Debian,a=testing,n=buster,l=Debian,c=contrib
     origin mirror.steadfast.net
 750 http://mirror.steadfast.net/debian/ testing/main amd64 Packages
     release o=Debian,a=testing,n=buster,l=Debian,c=main
     origin mirror.steadfast.net
 500 http://ftp.us.debian.org/debian/ stable/non-free Translation-en
 500 http://ftp.us.debian.org/debian/ stable/main Translation-en
 500 http://ftp.us.debian.org/debian/ stable/contrib Translation-en
 900 http://ftp.us.debian.org/debian/ stable/non-free amd64 Packages
     release v=9.0,o=Debian,a=stable,n=stretch,l=Debian,c=non-free
     origin ftp.us.debian.org
 900 http://ftp.us.debian.org/debian/ stable/contrib amd64 Packages
     release v=9.0,o=Debian,a=stable,n=stretch,l=Debian,c=contrib
     origin ftp.us.debian.org
 900 http://ftp.us.debian.org/debian/ stable/main amd64 Packages
     release v=9.0,o=Debian,a=stable,n=stretch,l=Debian,c=main
     origin ftp.us.debian.org
 500 http://mirror.steadfast.net/debian/ stable/non-free Translation-en
 500 http://mirror.steadfast.net/debian/ stable/main Translation-en
 500 http://mirror.steadfast.net/debian/ stable/contrib Translation-en
 900 http://mirror.steadfast.net/debian/ stable/non-free amd64 Packages
     release v=9.0,o=Debian,a=stable,n=stretch,l=Debian,c=non-free
     origin mirror.steadfast.net
 900 http://mirror.steadfast.net/debian/ stable/contrib amd64 Packages
     release v=9.0,o=Debian,a=stable,n=stretch,l=Debian,c=contrib
     origin mirror.steadfast.net
 900 http://mirror.steadfast.net/debian/ stable/main amd64 Packages
     release v=9.0,o=Debian,a=stable,n=stretch,l=Debian,c=main
     origin mirror.steadfast.net
 500 http://security.debian.org/ testing/updates/non-free Translation-en
 500 http://security.debian.org/ testing/updates/main Translation-en
 500 http://security.debian.org/ testing/updates/contrib Translation-en
1000 http://security.debian.org/ testing/updates/non-free amd64 Packages
     release o=Debian,a=testing,n=buster,l=Debian-Security,c=non-free
     origin security.debian.org
1000 http://security.debian.org/ testing/updates/contrib amd64 Packages
     release o=Debian,a=testing,n=buster,l=Debian-Security,c=contrib
     origin security.debian.org
1000 http://security.debian.org/ testing/updates/main amd64 Packages
     release o=Debian,a=testing,n=buster,l=Debian-Security,c=main
     origin security.debian.org
 500 http://security.debian.org/ stable/updates/non-free Translation-en
 500 http://security.debian.org/ stable/updates/main Translation-en
 500 http://security.debian.org/ stable/updates/contrib Translation-en
1000 http://security.debian.org/ stable/updates/non-free amd64 Packages
     release v=9,o=Debian,a=stable,n=stretch,l=Debian-Security,c=non-free
     origin security.debian.org
1000 http://security.debian.org/ stable/updates/contrib amd64 Packages
     release v=9,o=Debian,a=stable,n=stretch,l=Debian-Security,c=contrib
     origin security.debian.org
1000 http://security.debian.org/ stable/updates/main amd64 Packages
     release v=9,o=Debian,a=stable,n=stretch,l=Debian-Security,c=main
     origin security.debian.org
 900 http://dl.google.com/linux/chrome/deb/ stable/main amd64 Packages
     release v=1.0,o=Google, Inc.,a=stable,n=stable,l=Google,c=main
     origin dl.google.com
 500 http://ftp.us.debian.org/debian/ experimental/non-free Translation-en
 500 http://ftp.us.debian.org/debian/ experimental/main Translation-en
 500 http://ftp.us.debian.org/debian/ experimental/contrib Translation-en
   1 http://ftp.us.debian.org/debian/ experimental/non-free amd64 Packages
     release o=Debian,a=experimental,n=experimental,l=Debian,c=non-free
     origin ftp.us.debian.org
   1 http://ftp.us.debian.org/debian/ experimental/contrib amd64 Packages
     release o=Debian,a=experimental,n=experimental,l=Debian,c=contrib
     origin ftp.us.debian.org
   1 http://ftp.us.debian.org/debian/ experimental/main amd64 Packages
     release o=Debian,a=experimental,n=experimental,l=Debian,c=main
     origin ftp.us.debian.org
 500 http://mirror.steadfast.net/debian/ experimental/non-free Translation-en
 500 http://mirror.steadfast.net/debian/ experimental/main Translation-en
 500 http://mirror.steadfast.net/debian/ experimental/contrib Translation-en
   1 http://mirror.steadfast.net/debian/ experimental/non-free amd64 Packages
     release o=Debian,a=experimental,n=experimental,l=Debian,c=non-free
     origin mirror.steadfast.net
   1 http://mirror.steadfast.net/debian/ experimental/contrib amd64 Packages
     release o=Debian,a=experimental,n=experimental,l=Debian,c=contrib
     origin mirror.steadfast.net
   1 http://mirror.steadfast.net/debian/ experimental/main amd64 Packages
     release o=Debian,a=experimental,n=experimental,l=Debian,c=main
     origin mirror.steadfast.net
 500 http://linux.dropbox.com/debian/ jessie/main i386 Packages
     release o=Dropbox.com,a=jessie,n=jessie,l=Dropbox Debian Repository,c=main
     origin linux.dropbox.com
 500 http://linux.dropbox.com/debian/ jessie/main amd64 Packages
     release o=Dropbox.com,a=jessie,n=jessie,l=Dropbox Debian Repository,c=main
     origin linux.dropbox.com
 500 https://download.docker.com/linux/debian/ jessie/stable amd64 Packages
     release o=Docker,a=jessie,l=Docker CE,c=stable
     origin download.docker.com
 500 http://ftp.us.debian.org/debian/ jessie-updates/main Translation-en
 500 http://ftp.us.debian.org/debian/ jessie-updates/main amd64 Packages
     release o=Debian,a=oldstable-updates,n=jessie-updates,l=Debian,c=main
     origin ftp.us.debian.org
 500 http://security.debian.org/ jessie/updates/main Translation-en
1000 http://security.debian.org/ jessie/updates/main amd64 Packages
     release v=8,o=Debian,a=oldstable,n=jessie,l=Debian-Security,c=main
     origin security.debian.org
 500 http://ftp.us.debian.org/debian/ jessie/main Translation-en
 500 http://ftp.us.debian.org/debian/ jessie/main amd64 Packages
     release v=8.8,o=Debian,a=oldstable,n=jessie,l=Debian,c=main
     origin ftp.us.debian.org
Pinned packages:
  • Could you edit your question to add the output of apt-cache policy? – Stephen Kitt Jun 18 '17 at 17:31
  • Thanks; there’s something odd with your setup, could you also add your sources.list and pinning preferences? Basically, describe the changes you made... – Stephen Kitt Jun 18 '17 at 17:38
  • @StephenKitt I've included each of the files in question. Apologies if the dump is overkill. – Brandon Arnold Jun 18 '17 at 17:54
  • @StephenKitt You also asked for pinning preferences--I just included those, too. – Brandon Arnold Jun 18 '17 at 18:24
3

Oh, wow. That is one serious mixture of Debian repositories...

You got caught by the Debian 9 release today. Because you reference suites by release type instead of by code name (apart from Jessie), your latest dist-upgrade tried to upgrade to Stretch but the higher priorities from security upgrades in Jessie caused conflicts.

You need to pick one release and stick to it; if you really want to pull in packages from other releases, you need to set up priorities properly. I recommend restoring the status quo on Jessie to see if that allows dist-upgrade to complete:

  • disable experimental.list, testing.list and unstable.list;
  • in security.list, replace stable with jessie and remove the testing line;
  • remove your pin preferences.
  • Thank you for your detailed knowledge and help with this! I'm going to process it and make the changes, and come back and report afterwards. – Brandon Arnold Jun 18 '17 at 18:27
  • 3
    Please read this wiki.debian.org/DontBreakDebian . Scroll down to "Don't make a FrankenDebian". – user8779 Jun 18 '17 at 18:29
  • @arochester That is advice I should have heeded when I ignored the bad smell and followed this ServerFault post serverfault.com/a/382101 which already had comments from people who'd broken their system. I hope I've repaired my FrankenDebian situation now. – Brandon Arnold Jun 18 '17 at 18:46
  • @StephenKitt I believe I've repaired matters now; the security.list change you referenced in bullet point 2 I've only altered slightly by commenting out both lines, because the jessie line would be a duplicate of one that already exists in the root /etc/apt/sources.list file. – Brandon Arnold Jun 18 '17 at 18:48
  • @StephenKitt As a result, I see quite a lengthy dist-upgrade task that will soon happen. I should pull the trigger and update, right? 948 upgraded, 620 newly installed, 123 to remove and 0 not upgraded. Need to get 1,032 MB/1,032 MB of archives. After this operation, 1,334 MB of additional disk space will be used. – Brandon Arnold Jun 18 '17 at 18:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.