26

I have the following on my /etc/fuse.conf file:

# Set the maximum number of FUSE mounts allowed to non-root users.                       
# The default is 1000.                                                                   
#                                                                                        
#mount_max = 1000                                                                        

# Allow non-root users to specify the 'allow_other' or 'allow_root'                      
# mount options.                                                                         
#                                                                                        
user_allow_other    

But when I try to mount a remote path with the option allow_other:

> sshfs name@server:/remote/path /local/path -o allow_other

I get:

fusermount: failed to open /etc/fuse.conf: Permission denied
fusermount: option allow_other only allowed if 'user_allow_other' is set in /etc/fuse.conf

I have triple checked and the option user_allow_other is uncommented in my fuse.conf,as I copied above.

I have also executed sudo adduser my_user_name fuse (not sure if this is needed though), but I still get the same problem.

Why is it not parsing the /etc/fuse.conf file correctly?

2 Answers 2

28

Given the message failed to open /etc/fuse.conf: Permission denied, I suggest

chmod a+r /etc/fuse.conf
3
  • This is the correct answer
    – MountainX
    Commented Aug 24, 2017 at 3:55
  • @MountainX it would be nice to know why exactly
    – avp
    Commented Apr 23, 2021 at 8:36
  • It will be nice to have the script to revert it, for people that doesn't understand chmod at all ...
    – m3nda
    Commented Oct 11, 2021 at 18:51
25

A better solution might be to add the user to the fuse group, i.e.:

addgroup <username> fuse
4
  • 7
    Then log out and log back in!
    – Dave
    Commented Sep 9, 2013 at 1:58
  • 4
    And add existing user to fuse as secondary group: usermod -a -G existing_user fuse # in case addgroup is not present on your system Commented May 7, 2016 at 8:25
  • 2
    on ubuntu 20.04 i tried that but got addgroup: The group fuse' does not exist.`
    – dan carter
    Commented Sep 27, 2021 at 0:32
  • 3
    Group fuse was eliminated after Debian 8.
    – Paul
    Commented May 29, 2022 at 23:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .