0

osinfo :

cat /etc/*-release                                                                                                                                                                                                                                       
DISTRIB_ID=neon
DISTRIB_RELEASE=16.04
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION="KDE neon User Edition 5.10"
NAME="KDE neon"
VERSION="5.10"
ID=neon
ID_LIKE="ubuntu debian"
PRETTY_NAME="KDE neon User Edition 5.10"
VERSION_ID="16.04"
HOME_URL="http://neon.kde.org/"
SUPPORT_URL="http://neon.kde.org/"
BUG_REPORT_URL="http://bugs.kde.org/"
VERSION_CODENAME=xenial
UBUNTU_CODENAME=xenial

My problem : when i do apt-get update or install or whatever, i get the same thing (maybe slightly different). I suspect it has something to do with lightdm or sddm (i don't really know what they do). So i tried to purge and reinstall them. I'm afraid i made it a bit worse, but not too bad (since everything else on the os still seems to be working). I wasn't fooling around with anything when this first occurred.

Error :

[sudo] password for alex: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Entering ResolveByKeep 50%
Calculating upgrade... Done
The following packages will be upgraded:
  flashplugin-installer
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
13 not fully installed or removed.
Need to get 6.834 B of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 http://be.archive.ubuntu.com/ubuntu xenial-updates/multiverse amd64 flashplugin-installer amd64 26.0.0.131ubuntu0.16.04.1 [6.834 B]
Fetched 6.834 B in 0s (39,0 kB/s)                
Preconfiguring packages ...
(Reading database ... 191730 files and directories currently installed.)
Preparing to unpack .../flashplugin-installer_26.0.0.131ubuntu0.16.04.1_amd64.deb ...
Unpacking flashplugin-installer (26.0.0.131ubuntu0.16.04.1) over (26.0.0.126ubuntu0.16.04.1) ...
Processing triggers for update-notifier-common (3.168.4) ...
flashplugin-installer: processing...
flashplugin-installer: downloading http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_20170616.1.orig.tar.gz
Get:1 http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_20170616.1.orig.tar.gz [30,4 MB]
Fetched 30,4 MB in 8s (3.494 kB/s)                                                                                                                                                                                                                                            
W: Can't drop privileges for downloading as file '/var/lib/update-notifier/package-data-downloads/partial/adobe-flashplugin_20170616.1.orig.tar.gz' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)
Installing from local file /var/lib/update-notifier/package-data-downloads/partial/adobe-flashplugin_20170616.1.orig.tar.gz
Flash Plugin installed.
Setting up lightdm (1.18.3-0ubuntu1.1) ...
insserv: warning: script 'K07smfpd' missing LSB tags and overrides
insserv: warning: script 'smfpd' missing LSB tags and overrides
insserv: There is a loop at service plymouth if started
insserv: There is a loop between service plymouth and procps if started
insserv:  loop involving service procps at depth 2
insserv:  loop involving service udev at depth 1
insserv: Starting smfpd depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Max recursions depth 99 reached
insserv:  loop involving service bluetooth at depth 1
insserv: Starting smfpd depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: There is a loop between service smfpd and hwclock if started
insserv:  loop involving service hwclock at depth 1
insserv: There is a loop at service smfpd if started
insserv: Starting smfpd depends on plymouth and therefore on system facility `$all' which can not be true!
insserv:  loop involving service networking at depth 4
insserv:  loop involving service checkroot at depth 4
insserv:  loop involving service mountdevsubfs at depth 2
insserv: Starting smfpd depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: There is a loop between service plymouth and urandom if started
insserv:  loop involving service urandom at depth 4
insserv: Starting smfpd depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package lightdm (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up grub-common (2.02~beta2-36ubuntu3.11) ...
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
insserv: warning: script 'K07smfpd' missing LSB tags and overrides
insserv: warning: script 'smfpd' missing LSB tags and overrides
insserv: There is a loop at service plymouth if started
insserv: There is a loop between service plymouth and procps if started
insserv:  loop involving service procps at depth 2
insserv:  loop involving service udev at depth 1
insserv: Starting smfpd depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Max recursions depth 99 reached
insserv:  loop involving service bluetooth at depth 1
insserv: Starting smfpd depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: There is a loop between service smfpd and hwclock if started
insserv:  loop involving service hwclock at depth 1
insserv: There is a loop at service smfpd if started
insserv: Starting smfpd depends on plymouth and therefore on system facility `$all' which can not be true!
insserv:  loop involving service networking at depth 4
insserv:  loop involving service checkroot at depth 4
insserv:  loop involving service mountdevsubfs at depth 2
insserv: Starting smfpd depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: There is a loop between service plymouth and urandom if started
insserv:  loop involving service urandom at depth 4
insserv: Starting smfpd depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package grub-common (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of grub2-common:
 grub2-common depends on grub-common (= 2.02~beta2-36ubuntu3.11); however:
  Package grub-common is not configured yet.

dpkg: error processing package grub2-common (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of grub-efi-amd64-bin:
 grub-efi-amd64-bin depends on grub-common (= 2.02~beta2-36ubuntu3.11); however:
  Package grub-common is not configured yet.

dpkg: error processing package grub-efi-amd64-bin (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of grub-efi-amd64:
 grub-efi-amd64 depends on grub-common (= 2.02~beta2-36ubuntu3.11); however:
  Package grub-common is not configured yet.
 grub-efi-amd64 depends on grub2-common (= 2.02~beta2-36ubuntu3.11); however:
  Package grub2-common is not configured yet.
 grub-efi-amd64 depends on grub-efi-amd64-bin (= 2.02~beta2-36ubuntu3.11); however:
  Package grub-efi-amd64-bin is not configured yet.

dpkg: error processing package grub-efi-amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of grub-efi:
 grub-efi depends on grub-common (= 2.02~beta2-36ubuntu3.11); however:
  Package grub-common is not configured yet.
 grub-efi depends on grub-efi-amd64 (= 2.02~beta2-36ubuntu3.11); however:
  Package grub-efi-amd64 is not configured yet.

dpkg: error processing package grub-efi (--configure):
 dependency problems - leaving unconfigured
Setting up cgmanager (0.39-2ubuntu5) ...
insserv: warning: script 'K07smfpd' missing LSB tags and overrides
insserv: warning: script 'smfpd' missing LSB tags and overrides
insserv: There is a loop at service plymouth if started
insserv: There is a loop between service plymouth and procps if started
insserv:  loop involving service procps at depth 2
insserv:  loop involving service udev at depth 1
insserv: Starting smfpd depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Max recursions depth 99 reached
insserv:  loop involving service bluetooth at depth 1
insserv: Starting smfpd depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: There is a loop between service smfpd and hwclock if started
insserv:  loop involving service hwclock at depth 1
insserv: There is a loop at service smfpd if started
insserv: Starting smfpd depends on plymouth and therefore on system facility `$all' which can not be true!
insserv:  loop involving service networking at depth 4
insserv:  loop involving service checkroot at depth 4
insserv:  loop involving service mountdevsubfs at depth 2
insserv: Starting smfpd depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: There is a loop between service plymouth and urandom if started
insserv:  loop involving service urandom at depth 4
insserv: Starting smfpd depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package cgmanager (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up ebtables (2.0.10.4-3.4ubuntu2) ...
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
insserv: warning: script 'K07smfpd' missing LSB tags and overrides
insserv: warning: script 'smfpd' missing LSB tags and overrides
insserv: There is a loop at service plymouth if started
insserv: There is a loop between service plymouth and procps if started
insserv:  loop involving service procps at depth 2
insserv:  loop involving service udev at depth 1
insserv: Starting smfpd depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Max recursions depth 99 reached
insserv:  loop involving service bluetooth at depth 1
insserv: Starting smfpd depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: There is a loop between service smfpd and hwclock if started
insserv:  loop involving service hwclock at depth 1
insserv: There is a loop at service smfpd if started
insserv: Starting smfpd depends on plymouth and therefore on system facility `$all' which can not be true!
insserv:  loop involving service networking at depth 4
insserv:  loop involving service checkroot at depth 4
insserv:  loop involving service mountdevsubfs at depth 2
insserv: Starting smfpd depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: There is a loop between service plymouth and urandom if started
insserv:  loop involving service urandom at depth 4
insserv: Starting smfpd depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package ebtables (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of libvirt-bin:
 libvirt-bin depends on cgmanager | cgroup-lite | cgroup-bin; however:
  Package cgmanager is not configured yet.
  Package cgroup-lite is not installed.
  Package cgroup-bin is not installed.
 libvirt-bin depends on ebtables; however:
  Package ebtables is not configured yet.

dpkg: error processing package libvirt-bin (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of os-prober:
 os-prober depends on grub-common; however:
  Package grub-common is not configured yet.

dpkg: error processing package os-prober (--configure):
 dependency problems - leaving unconfigured
Setting up sddm (0.14.0-1~2.gbpf70012+16.04+xenial+build8) ...
dpkg: error processing package sddm (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up virtualbox (5.0.40-dfsg-0ubuntu1.16.04.1) ...
insserv: warning: script 'K07smfpd' missing LSB tags and overrides
insserv: warning: script 'smfpd' missing LSB tags and overrides
insserv: There is a loop at service plymouth if started
insserv: There is a loop between service plymouth and procps if started
insserv:  loop involving service procps at depth 2
insserv:  loop involving service udev at depth 1
insserv: Starting smfpd depends on plymouth and therefore on system facility `$all' which can not be true!

insserv: Max recursions depth 99 reached
insserv:  loop involving service bluetooth at depth 1
insserv: Starting smfpd depends on plymouth and therefore on system facility `$all' which can not be true!

insserv: There is a loop between service smfpd and hwclock if started
insserv:  loop involving service hwclock at depth 1
insserv: There is a loop at service smfpd if started
insserv: Starting smfpd depends on plymouth and therefore on system facility `$all' which can not be true!
insserv:  loop involving service networking at depth 4
insserv:  loop involving service checkroot at depth 4
insserv:  loop involving service mountdevsubfs at depth 2
insserv: Starting smfpd depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: There is a loop between service plymouth and urandom if started
insserv:  loop involving service urandom at depth 4
insserv: Starting smfpd depends on plymouth and therefore on system facility `$all' which can not be true!

insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package virtualbox (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of virtualbox-qt:
 virtualbox-qt depends on virtualbox (= 5.0.40-dfsg-0ubuntu1.16.04.1); however:
  Package virtualbox is not configured yet.

dpkg: error processing package virtualbox-qt (--configure):
 dependency problems - leaving unconfigured
Setting up flashplugin-installer (26.0.0.131ubuntu0.16.04.1) ...
Errors were encountered while processing:
 lightdm
 grub-common
 grub2-common
 grub-efi-amd64-bin
 grub-efi-amd64
 grub-efi
 cgmanager
 ebtables
 libvirt-bin
 os-prober
 sddm
 virtualbox
 virtualbox-qt
E: Sub-process /usr/bin/dpkg returned an error code (1)

note : i deleted a few : nsserv: Starting smfpd depends on plymouth and therefore on system facility `$all' which can not be true! lines so the questions wouldn't be too big.

How would i best go about fixing this?

  • I suspect it's related to 3rd party (Samsung) printer drivers - see this similar askubuntu Q&A: 16.04 LTS Update fails - Errors were encountered while processing util-linux – steeldriver Jun 17 '17 at 0:35
  • I do not know how you found it, because i searched and didn't find that answer. I don't know how to upvote, but if i could i would. – user3452559 Jun 17 '17 at 11:57
  • I guess my google-fu was just stronger - it might be worth editing your title so that it refers to "insserv: warning: script 'K07smfpd' missing LSB tags and overrides" to make your Q&A easier for others to find in the future – steeldriver Jun 17 '17 at 12:41
2

Thanks to steeldriver and his comment i could read this question on Ask Ubuntu: 16.04 LTS Update fails - Errors were encountered while processing util-linux. I don't have a samsung printer/driver but it did get me to try to uninstall my dell printer driver.

To uninstall :

cd /opt/DELL/mfp/uninstall
sudo ./uninstall.sh 

Doing this solved the problem.

1

Seems the same issue is caused by other printers as well.

Run uninstall.sh in /opt/<Printer Vendor>/mfp/uninstall.

I had a Xerox printer installed some time ago, and not currently using it. Removing the driver made the updates working.

1

I use panasonic printer.

I edit the file panasoniclpd-init:

sudo gedit /etc/init.d/panasoniclpd-init

Add this:

### BEGIN INIT INFO
Provides:          panasoniclpd-init
Required-Start:    $all
Required-Stop:     $all
Default-Start:     2 3 4 5
Default-Stop:      0 1 6
Short-Description: Panasonic MFS driver for MB20xx
### END INIT INFO
  • ### BEGIN INIT INFO [/p] # Provides: panasoniclpd-init # Required-Start: $all # Required-Stop: $all # Default-Start: 2 3 4 5 # Default-Stop: 0 1 6 # Short-Description: Panasonic MFS driver for MB20xx ### END INIT INFO – user271434 Jan 19 '18 at 18:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.