1

I am using the awesome window manager running Debian 8. I am unable to open up the synaptic package manager when i go to the menubar using right click on the desktop > Debian>Applications>System>Package Manager>Synaptic Package Manager. I then get a prompt in the terminal for the root password, but after giving the password the terminal closes and nothing happens. Can anyone help?

  • 2
    I think this is a problem caused by a bug when you disable sudo in some environments. – Luciano Andress Martini Jun 16 '17 at 14:09
  • @LucianoAndressMartini Could you explain a bit more and how to enable the sudo again? – amirt Jun 16 '17 at 14:17
  • I run graphical interface only for web browsing... so i dont have a good aknowledge about DMs... but that is because when you try to open synaptic some common procedure tries to get the elevation. But the library that is doing this job is not working without sudo, the correct procedure was to ask the root password and call the program with su -c for example. To re-add a user to sudo you can try adduser youruser sudo . If you can call synpatic from a terminal try su -c 'synaptic' and see what happerns, if there is a error please post here. – Luciano Andress Martini Jun 16 '17 at 14:34
2

On Ubuntu 16.04 LTS, on FVWM window manager, I kind of observer the same thing. When I press Alt+F1 then I go to:

XDG Menu > Gnome Applications > System Tools > Administration > Synaptic Package Manager

Nothing happens.

Then, on xterm I run $ synaptic and I receive the following message:

enter image description here

On xterm, when I run $ sudo synaptic the program starts normally without any warning/error message.

0

Make sure you have mate-polkit and mate-polkit-bin installed and it is autostarted.

This package eases using mate-polkit as PolicyKit-1 authentication agent on non-MATE desktop environments that don't auto-launch their own authentication agent (e.g., i3, awesome, ratpoison and alike).

(mate-polkit-bin)

-1

Go to terminal (Ctrl+Alt+T) and type:

sudo synaptic

type in the password (if it asks) then instantly synaptic package manager should launch.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.