0

I am receiving the following error when I'm trying to run the compiled litecoin-qt,

Error while loading shared libraries: libdb_cxx-4.8.so: cannot open shared object file 

How do I make a new path for the berkeley lib?

export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:/usr/local/lib"

Is it somewhere in /etc/ld.so.conf.d? If so, what command should I run?

Whenever I try to find where libdb_cxx-4.8.so is installed,

$ whereis libdb_cxx-4.8.so 

The output is just this,

libdb_cxx-4.8: 

Thanks for your time.

closed as off-topic by Stephen Kitt, Rui F Ribeiro, mdpc, G-Man, phk Jun 17 '17 at 8:46

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Stephen Kitt, Rui F Ribeiro, mdpc
If this question can be reworded to fit the rules in the help center, please edit the question.

  • find / | grep libdb_cxx-4.8.so Can you do this and show us where is libdb? – Luciano Andress Martini Jun 16 '17 at 14:08
  • find / | grep libdb_cxx-4.8.so gives /usr/local/BerkeleyDB.4.8/lib/ibdb_cxx-4.8.so – Zacharin Jun 16 '17 at 14:13
  • /home/*/db-4.8.30.NC/build_unix/.libs/libdb_cxx-4.8.so /home/*/litecoin/src/db-4.8.30.NC/build_unix/.libs/libdb_cxx-4.8.so /home/*/litecoin/src/qt/db-4.8.30.NC/build_unix/.libs/libdb_cxx-4.8.so /home/*/Desktop/db-4.8.30.NC/build_unix/.libs/libdb_cxx-4.8.so – Zacharin Jun 16 '17 at 14:16
  • Run ldd binary_name and paste the result into the question, not as a comment. And what distribution and release are you running? – Faheem Mitha Jun 16 '17 at 14:33
  • ldd libdb_cxx-4.8.so gives nothing..? – Zacharin Jun 16 '17 at 15:15
1

I think that will be able to solve your problem:

export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:/usr/local/BerkeleyDB.4.8/lib" 
  • I pasted that into the terminal, then Cd'd into my litecoin directory, and i still have the same error, Error while loading shared libraries: libdb_cxx-4.8.so: cannot open shared object file – Zacharin Jun 16 '17 at 14:19
  • Hum i think that some required library for libdb is missing, run your program using gdb yourprogram and then do a 'run'. – Luciano Andress Martini Jun 16 '17 at 14:38
  • Whenever i try to gdb run ./home/*/Desktop/litecoin-0.13.2/litecoin-qt = "No executable file specified" Or gdb run ./litecoin-qt , it gives the same result – Zacharin Jun 16 '17 at 14:50
  • My litecoin-qt is also not recognised as a application, but as a "shared library" "Type: shared library (application/x=shared.. – Zacharin Jun 16 '17 at 14:59
  • Is just gdb /home/youruser/Desktop/litecoin-0.13.2/litecoin-qt , after that you type the command "run" and then press enter. – Luciano Andress Martini Jun 16 '17 at 15:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.