1

I have the following issue with a fresh arch-linux installation: in KDE/plasma with SDDM neither su or sudo work. I tried to use them in both konsole and xterm. What does also not work is authentication after the screen locker starts (this means I cannot unlock the screen). Initial login with SDDM works. (So to "unlock" the session I have to restart the SDDM service).

If I switch to another session (using CTRL-F2, etc.) I can use su and sudo as expected there.

What I have tried so far is reinstalling 'pambase' and 'pam' and check the configuration for /etc/pam.d/system-auth:

#%PAM-1.0

auth      required  pam_unix.so     try_first_pass nullok
auth      optional  pam_permit.so
auth      required  pam_env.so

account   required  pam_unix.so
account   optional  pam_permit.so
account   required  pam_time.so

password  required  pam_unix.so     try_first_pass nullok sha512 shadow
password  optional  pam_permit.so

session   required  pam_limits.so
session   required  pam_unix.so
session   optional  pam_permit.so

And of course also /etc/pam.d/sddm:

#%PAM-1.0

auth        include     system-login
account     include     system-login
password    include     system-login
session     include     system-login

What might be interessting is the output of journalctl after calling su:

Apr 28 14:42:30 zenbook su[7401]: pam_unix(su:auth): authentication failure; logname=myuser uid=1000 euid=0 tty=pts/2 ruser=myuser rhost=  user=
Apr 28 14:42:32 zenbook su[7401]: FAILED SU (to root) myuser on pts/2

Or after calling 'sudo nano':

Apr 28 15:06:29 zenbook sudo[7542]: pam_unix(sudo:auth): authentication failure; logname=myuser uid=1000 euid=0 tty=/dev/pts/2 rfuser=myuser rhos
Apr 28 15:06:43 zenbook sudo[7542]: myuser : 3 incorrect password attempts ; TTY=pts/2 ; PWD=/home/myuser ; USER=root ; COMMAND=/usr/bin/nano

I don't know what further information would be helpful to resolve this issue. I would be happy to provide more information if required.

Note: I have also asked the question on the arch forum without getting a reply so far.

Edit:

So far I think it is related to SDDM because I have the same issue for example in Enlitenment when run with SDDM. If I start however an X11 session without SDDM su and sudo work without problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.