1

I am running Ubuntu 17.04. I installed ubuntu-gnome before upgrading to 17.04 and it worked fine. However, after updating I cannot login when I select Gnome desktop environment. It looks as if it going to log in and then the screen turns black and it brings me back to the login screen. Only unit works. I have tried changing the ownership of .Xauthority to my user but that didn't fix the problem. If I su root and then "startx" I am able to get into Gnome but that's it.

I CAN login using Unity and everything works fine. I have also tried reinstalling gnome and purging nvidia drivers.

Below is part of my .xsession-errors. I have not been able to find any error listed in that file so I'm not sure how to fix the problem.

Any ideas?

/local/games:/snap/bin:/usr/lib/jvm/java-8-oracle/bin:/usr/lib/jvm/java-8-oracle/db/bin:/usr/lib/jvm/java-8-oracle/jre/bin
    dbus-update-activation-environment: setting GTK_IM_MODULE=ibus
    dbus-update-activation-environment: setting _=/usr/bin/dbus-update-activation-environment
    Xsession: X session started for root at Tue Jun 13 17:50:46 CDT 2017
    dbus-update-activation-environment: systemd --user not found, ignoring --systemd argument
    dbus-update-activation-environment: setting DISPLAY=:0
    dbus-update-activation-environment: setting XAUTHORITY=/home/caleblawrence/.Xauthority
    localuser:root being added to access control list
    dbus-update-activation-environment: systemd --user not found, ignoring --systemd argument
    dbus-update-activation-environment: setting GTK_MODULES=gail:atk-bridge
    gpgconf: warning: can not open config file /home/caleblawrence/.gnupg/gpg-agent.conf: No such file or directory
    dbus-update-activation-environment: systemd --user not found, ignoring --systemd argument
    dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
    dbus-update-activation-environment: setting QT_LINUX_ACCESSIBILITY_ALWAYS_ON=1
    OpenGL version: 3.
    dbus-update-activation-environment: systemd --user not found, ignoring --systemd argument
    dbus-update-activation-environment: setting SUDO_GID=1000
    dbus-update-activation-environment: setting MAIL=/var/mail/root
    dbus-update-activation-environment: setting USER=root
    dbus-update-activation-environment: setting HOME=/home/caleblawrence
    dbus-update-activation-environment: setting GTK_MODULES=gail:atk-bridge
    dbus-update-activation-environment: setting QT_LINUX_ACCESSIBILITY_ALWAYS_ON=1
    dbus-update-activation-environment: setting DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-knFOsGORh1,guid=a32164b22f30cc2a3788b1d959406c46
    dbus-update-activation-environment: setting SUDO_UID=1000
    dbus-update-activation-environment: setting IM_CONFIG_PHASE=1
    dbus-update-activation-environment: setting LOGNAME=root
    dbus-update-activation-environment: setting TERM=linux
    dbus-update-activation-environment: setting USERNAME=root
    dbus-update-activation-environment: setting WINDOWPATH=2
    dbus-update-activation-environment: setting GTK2_MODULES=overlay-scrollbar
    dbus-update-activation-environment: setting PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/snap/bin
    dbus-update-activation-environment: setting DISPLAY=:0
  • I've also purged any nvidia drivers and still have the problem. – Caleb Lawrence Jun 15 '17 at 21:07
  • Just to be clear: You can log in, but not into the Gnome session? And why are you trying to run startx as root? While technically possible, that's at least some two levels away from how the system is meant to be used. – a CVn Jun 15 '17 at 21:23
  • FWIW, what you are describing sounds suspiciously like something early in the session startup is broken. I don't have any ready suggestions, but one thing you might definitely want to try is to reinstall GNOME through apt-get and make sure you are getting packages intended for your version of Ubuntu. – a CVn Jun 15 '17 at 21:24
  • @MichaelKjörling Yes I can login via Unity. I'll add that to the post - forgot to mention it. I'm not sure why I ran it root. I wanted to see if it would for root because it was not working for any other users. – Caleb Lawrence Jun 15 '17 at 21:25
  • @MichaelKjörling Ok, I'll check it out. I have reinstalled gnome and gdm a couple times now but I'll check out the versions more. Thanks. – Caleb Lawrence Jun 15 '17 at 21:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.