0

I have a strange issue. If I connect to Ethernet or wifi in my office, I get the internet. But I can't get the internet in the home wifi or my mobile phone hotspot.

I get the following when I try to open Google.com using my browser: DNS_PROBE_FINISHED_BAD_CONFIG

I tried this solution 1 2

Both of them Didn't work.

I tried flushing the DNS using dns-clean. It is still not fixing.

In summary, I can connect wifi only to employer's wifi. Apart from it, I can connect to wifi but internet is working.

Help would be much appreciated.

xyz-username@zyx-abc-computer-name:~$ route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         172.20.10.1     0.0.0.0         UG    600    0        0 wlp4s0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 wlp4s0
172.20.10.0     0.0.0.0         255.255.255.240 U     600    0        0 wlp4s0


xyz-username@xyz-abc-computer-name:~$ ifconfig
enp0s31f6 Link encap:Ethernet  HWaddr 54:ee:75:b1:51:60  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:21839 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9198 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:14318848 (14.3 MB)  TX bytes:1431218 (1.4 MB)
          Interrupt:16 Memory:f1200000-f1220000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:3700 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3700 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:5835931 (5.8 MB)  TX bytes:5835931 (5.8 MB)

wlp4s0    Link encap:Ethernet  HWaddr e4:a7:a0:df:74:9c  
          inet addr:172.20.10.6  Bcast:172.20.10.15  Mask:255.255.255.240
          inet6 addr: fe80::e86e:2246:44a:a2e5/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:35472 errors:0 dropped:0 overruns:0 frame:0
          TX packets:56362 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:26975714 (26.9 MB)  TX bytes:8620526 (8.6 MB)

xyz-username@xyz-abc-computer-name:~$ cat /etc/NetworkManager/NetworkManager.conf 
[main]
plugins=ifupdown,keyfile,ofono
dns=dnsmasq

[ifupdown]
managed=false
xyz-username@xyz-abc-computer-name:~$ cat /etc/n
nanorc         network/       networks       newt/          nsswitch.conf  
xyz-username@xyz-abc-computer-name:~$ cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback
xyz-username@xyz-abc-computer-name:~$ cat /etc/hosts
127.0.0.1   localhost
127.0.1.1   xyz-abc-computer-name








# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
xyz-username@xyz-abc-computer-name:~$ cat /etc/resolv.conf 
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN

domain  abc.net
search mou.abc.net abc.com abc.net
nameserver 172.23.1.16
nameserver 172.19.1.16
nameserver 172.21.1.16
options timeout:1 attempts:1
nameserver 127.0.1.1
search hsd1.wxy.comcast.net

xyz-username@xyz-abc-computer-name:~$ ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=56 time=50.1 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=56 time=46.8 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=56 time=237 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=56 time=186 ms
64 bytes from 8.8.8.8: icmp_seq=5 ttl=56 time=52.5 ms
64 bytes from 8.8.8.8: icmp_seq=6 ttl=56 time=50.1 ms
^Z
[1]+  Stopped                 ping 8.8.8.8
xyz-username@xyz-abc-computer-name:~$ nslookup google.com
;; connection timed out; no servers could be reached

xyz-username@xyz-abc-computer-name:~$ nslookup google.com 8.8.8.8
Server:     8.8.8.8
Address:    8.8.8.8#53

Non-authoritative answer:
Name:   google.com
Address: 172.217.11.14

xyz-username@xyz-abc-computer-name:~$ ls /etc/network/interfaces.d/
xyz-username@badri-abc-computer-name:~$ 
2
  • Given the updated information, try editing the /etc/resolve.conf to have a nameserver 8.8.8.8 entry first (note: it will be lost in the future; this is just a test). That might resolve the browser issue. The fact the nslookup google.com 8.8.8.8 worked again implies network connectivity.
    – KevinO
    Commented Jun 15, 2017 at 21:10
  • @KevinO: It worked for me. Thanks. I added nameserver 8.8.8.8 in /etc/resolv.conf. That did the trick. Commented Jun 15, 2017 at 21:35

1 Answer 1

0

As you can ping ip addresses of public DNS server 8.8.8.8 you have internet access and your gateway config is OK.
It seems your DNS servers are not serving properly.

Try changing your ISP's DNS servers with some public ones (8.8.8.8, 4.2.2.3 ,...)

if you're using network manager use its editor to use "Automatic (DHCP ) Addresses Only" and if you're using text mode update /etc/resolv.conf to use working DNS servers

1
  • It worked for me. Thanks. I added nameserver 8.8.8.8 in /etc/resolv.conf. That did the trick. Commented Jun 15, 2017 at 21:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .