I recently started learning Linux and I'm booting into Debian from USB. I'm not sure what I'm doing wrong but I cannot get my wifi up. Regular wired works perfectly.

iwconfig shows no wlan0. No messages about iwlwifi firmware in dmesg. lsmod shows iwlwifi loaded and used by cfg80211. I can modprobe iwlwifi off and on.

Below are some screen shots with some info. Sorry for the ugly picture. I was really trying to figure this out myself but not sure if its going to happen.

Results from:

uname -r; lsmod | grep iwl; dmesg | grep firm; lspci -nnk | grep -iA2 net

enter image description here

Updated to include 'lsh -C network'

enter image description here

Progress update:

Updating the kernel to 4.9 caused me to boot to black screen presumably because of a conflict with display drivers. I've attempted apt-get remove xserver-xorg-video-intel but the system responds by telling me it is not installed and so not removed. 'locate xorg' shows 3 files located in /usr/share/X11/xkb/rules and one in /usr/share/doc/keyboard-configuration. lshw -c video reveals 2 devices, both with configurations set to "latency=0" which I presume means they are not using separate drivers.

  • What type of wireless device do you have? (Run sudo lshw -C network)
    – Ariyan
    Jun 15 '17 at 18:46
  • I've updated original post to include this output.
    – Mike
    Jun 15 '17 at 20:14
  • Do note that Debian in particular has a tendency to be somewhat finicky in this regard. Not only because of their free software guidelines (DFSG), but also because it is an extremely conservative distribution and even the most recent release, fully updated, is commonly quite a long ways behind the underlying projects. (Critical fixes do get backported, but not new functionality or in this case hardware support.) While it can be a great learning experience, if you are new to Linux you might be better served by chosing some other distribution.
    – user
    Jun 15 '17 at 21:06

Your wifi card is Intel® Dual Band Wireless-AC 3165

According to Intel the official website the the wifi card should work on the kernel version 4.2 and higher.

Device                                               Kernels        Firmware    

Intel® Dual Band Wireless-AC 3165 
(starting from firmware XX.XX.13.0 and kernel 4.1)      4.2     iwlwifi-7265-ucode-

On debian jessie you need to install a new kernel from backports:

Edit your sources.list

apt edit-sources

Add the following line:

deb http://httpredir.debian.org/debian jessie-backports main contrib non-free

Save your file then update

apt update

Search for available linux-image:

apt-cache search linux-image

Then install the new linux-image, e,g:

apt-get -t jessie-backports install linux-image-4.9.0-0.bpo.3-amd64

If you last command show a missing dependencies, install with:

apt-get -t jessie-backports package-name-here

Reboot your system

Now you can install the Intel driver as follow:

wget https://wireless.wiki.kernel.org/_media/en/users/drivers/iwlwifi-7265-ucode-
tar xvf iwlwifi-7265-ucode-
cd iwlwifi-7265-ucode-
cp iwlwifi* /lib/firmware
rmmod iwlwifi
modprobe iwlwifi

Or install firmware-iwlwifi from backports then reload the driver.

  • 1
    Yes; a quick Google search for debian 8086:4010 seems to suggest that a somewhat more modern kernel is needed. It's amazing at times what searching for the PCI ID can uncover.
    – user
    Jun 15 '17 at 21:01
  • I like this above answer, it seems like it should work but it causes me to boot into a black screen. I wiped my device and tried it again with several different kernel versions but each one causes me to boot into a black screen. Maybe I should just try switching to Ubuntu though I hate to give up on Debian. I checked the logs in '/var/log/apt' but didnt see anything about missing packages.
    – Mike
    Jun 16 '17 at 13:58
  • @Mike solving the black screen using the Stephen kitt answer unix.stackexchange.com/questions/307210/…
    – GAD3R
    Jun 16 '17 at 14:05
  • Updated above with progress here.
    – Mike
    Jun 16 '17 at 18:47
  • 1
    Got it working! Thanks everyone. Black screen was solved by adding 'nomodeset' in the boot screen @ GRUB, then making the fix permanent by editing '/etc/default/grub'. I'm sure there is some better way to do this but it works. Wifi was still down so i just installed firmware-iwlwifi and sure enough wlan0 showed up. The rest was just a matter of configuring /etc/network/interfaces to connect.
    – Mike
    Jun 21 '17 at 3:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.