I've recently started to follow a lecture about wireless network, and I bought an external wifi card called TL-WN722N from TP-LINK to use it for packet sniffing.

I tried to use it in a Kali Linux guest on VM Ware and didn't succeed, however I read that there are two versions of firmware the 1.0 and the 2.0, it appears that I've got the 2.0, which seems to have some problem with Linux distribution, I tried to install driver from the official web site but it didn't work:

cc1: some warnings being treated as errors scripts/Makefile.build:289: recipe for target '/home/lapinou/Desktop/rtl8188EUS_linux_v4.3.0.8_13968.20150417/core/rtw_debug.o' failed make[2]: * [/home/lapinou/Desktop/rtl8188EUS_linux_v4.3.0.8_13968.20150417/core/rtw_debug.o] Error 1 Makefile:1491: recipe for target 'module/home/lapinou/Desktop/rtl8188EUS_linux_v4.3.0.8_13968.20150417' failed make[1]: * [module/home/lapinou/Desktop/rtl8188EUS_linux_v4.3.0.8_13968.20150417] Error 2 make[1]: Leaving directory '/usr/src/linux-headers-4.8.0-52-generic' Makefile:1367: recipe for target 'modules' failed make: *** [modules] Error 2

When I lsusb :

Bus 001 Device 005: ID 2357:010c
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 002 Device 003: ID 0e0f:0002 VMware, Inc. Virtual USB Hub Bus 002 Device 002: ID 0e0f:0003 VMware, Inc. Virtual Mouse Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

It doesn't detect the name of the card, but the id 2357:010c seems to be the card.

I have tried to search across the internet many things but I have found nothing.

Now tree things:

  • Is this possible to make the version 2.0 work on Kali Linux ?
  • Does the version 2.0 include the monitor mode (which I need to sniff) ?
  • If not, what can I buy to sniff packet in wifi ?
  • This is more of a technical support question than a security question. You might be able to get help on Unix & Linux Stack Exchange. Jun 14, 2017 at 19:13

2 Answers 2


TL-WN722N v2 not working with kali (sniffing) but you still can use it.

    git clone https://github.com/lwfinger/rtl8188eu.git
    cd rtl8188eu/
    make all
    sudo make install
    sudo dkms add ./rtl8188eu
    sudo dkms build 8188eu/1.0
    sudo dkms install 8188eu/1.0
  • You answer should work after upgrading the kernel version to the latest available version and installing the appropriate linux-headers package.
    – GAD3R
    Jun 15, 2017 at 10:33

I have also tested this model TL-WN722N v2 it is not working with kali for packet injections but you can still use it though after installing its driver.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy