1

I have the Beaglebone powered through 5V and the ethernet in a open port on my PC. I have added the lines to /etc/network/interfaces

auto eth0
iface eth0 inet static
   address 192.168.1.80
   network 192.168.1.0
   netmask 255.255.255.0 

This comes up with

root@beaglebone:/var/lib/cloud9# ifconfig

eth0      Link encap:Ethernet  HWaddr 04:a3:16:b3:c3:b7  
          **inet addr:192.168.1.80**  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::6a3:16ff:feb3:c3b7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:745 errors:0 dropped:4 overruns:0 frame:0
          TX packets:46 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:119330 (116.5 KiB)  TX bytes:8226 (8.0 KiB)
          Interrupt:40 

root@beaglebone:/var/lib/cloud9# ip route

192.168.1.0/24 dev eth0  proto kernel  scope link  src 192.168.1.80 

192.168.7.0/30 dev usb0  proto kernel  scope link  src 192.168.7.2

root@beaglebone:/var/lib/cloud9# netstat -nr

Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
192.168.1.0     0.0.0.0         255.255.255.0   U         0 0          0 eth0
192.168.7.0     0.0.0.0         255.255.255.252 U         0 0          0 usb0

But when I try to ping 192.168.1.80, I get Host Unreachable.

Even when I log onto it through serial I get

Debian GNU/Linux 7 beaglebone ttyGS0

BeagleBoard.org Debian Image 2015-11-12

Support/FAQ: http://elinux.org/Beagleboard:BeagleBoneBlack_Debian
default username:password is [debian:temppwd]
The IP Address for eth0 is: 192.168.1.80
The IP Address for usb0 is: 192.168.7.2

What am I doing wrong?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.