0

I have a YOCTO image running on ARM based board(ICM 3011). I want to install Remmina (rdp client) on the image. The problem is I don't have apt-get on the image , I don't have any package managers either. I have tried downloading the tar file from remmina.org but cannot install it as I don't have cmake or make or gcc on the yocto image.

I have tried to run binaries from this site: https://packages.debian.org/search?keywords=remmina but when i run the binary it gives error "EXEC format error".

Can anyone please show me how to install Remmina on yocto (on a arm based processor) without using apt-get or cmake or building the source as I dont have compilers for that either.

  • Don't compile on the board, use a cross-compiler on your PC. – Gilles Jun 14 '17 at 23:45
  • Can you please elaborate the process? Should I compile it on my ubuntu PC with gcc and then port the binaries to Yocto. What files should I transfer ? – Adds Jun 15 '17 at 12:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.